If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

History "Last Visited" Sorts in Alphanumeric order, not by date

RESOLVED WORKSFORME

Status

()

Core
History: Global
RESOLVED WORKSFORME
16 years ago
5 years ago

People

(Reporter: Cory Dodt, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc3)
Gecko/20020523
BuildID:    2002052306

This is a subtle problem with the Last Visited column in the history sidebar. 
If you click on this column to sort by last visited (I think it is the default
anyway), the order the folders appear in is by the alphabetic name of the
folder.  For example, descending sort goes "Yesterday, Today, Older than 6 days,
6 days, 5 days, 4 days..."
because the folders start with Y, T, O, 6, 5, 4, ...  In an alphanumeric sort
this is what you'd expect, but they should be sorted by date, not by name.

See below for what I think is the correct sort order.


Reproducible: Always
Steps to Reproduce:
1. View->Show->Sidebar (or F9) if sidebar is not visible.
2. Under Tabs, make sure History is checked.
3. Pick the History tab in the sidebar.
4. Click the Last Visited column.

Actual Results:  Sorts folders into: Yesterday, Today, Older than 6 days, 5 days
ago, 4 days ago, 3 days ago, 2 days ago.

Expected Results:  Sort folders into: Today, Yesterday, 2 days ago, 3 days ago,
4 days ago, 5 days ago, 6 days ago, Older than 6 days.

This bug could be fixed easily by changing what the folders are named.    0 days
ago, 1 day ago, 2 days ago [ . . . ] 7 or more days ago.  Then you don't have to
change how the sorting works, because alphanumeric sort and date sort will do
the same thing.

Better still, make them sort by date.  Up to you.

Comment 1

16 years ago
--> history
Assignee: sgehani → blaker
Component: Sidebar → History: Global
QA Contact: sujay → claudius

Comment 2

15 years ago
Created attachment 99208 [details]
"Default" "no sorting by title" ordering on Mozilla??

History "list sorting" makes no sense:

If you click on the "title" tab, then you'll get the foldes as follows:
2, 3, 4, 5, 6 days ago; Older than 6 days, Today, Yesterday. Or the other way
round, of course. 

If you click a third time (so the "sorting" arrow is no longer visible on the
column heading), then you get:
2 days ago
Today
Older than 6 days
6 days ago
5, 4, 5 days ago
Yesterday!!

(See attachment)

Comment 3

15 years ago
Created attachment 99209 [details]
Odd sorting rules when sorting history by date

When choosing to view the "last visited" column on the history pane (sidebar),
the sorting rules have to be odd indeed:
We have the "date" foldes (yesterday, today, older than 6 days, 6 , 5, 4, 3, 2
days ago).
Then we have the "site" subfolders, that are sorted god-knows-how, and then the
different pages on the site, that _are_ sorted by date visited.

I don't know what's the logic, if any, but I think that if click on the "last
visited", I want to have _all_ the pages sorted by the time of my last visit,
no "separate by days" and "by sites".... In _any_ case, it _could_ be argued in
favour of separating the pages "by days" (as in "yesterday, 2 days ago," etc)
but that'd be all. And, of course, to have those folders properly sorted.

Comment 4

15 years ago
Dupe of bug 120983?

Comment 5

15 years ago
This may be the cause of similar odd behavior in Phoenix:

Opening the history sidebar (control+H) shows recently visited links in a
strange order that certainly isn't by last visited date, although the View
selector clearly indicates "By Last Visited".  Clicking on the same View
selection again rearranges the links into the expected order.

(Phoenix 0.5, Win32.)
(Reporter)

Comment 6

15 years ago
Cannot confirm this bug is still happening in Moz 1.2.1.  I followed my own
instructions to produce the results, and I now get 
[Today, Yesterday, 2 days, 3 days, 4 days, 5 days, 6 days, Older]

which is the expected sort.

Comment 7

15 years ago

*** This bug has been marked as a duplicate of 120983 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 8

15 years ago
sorry, reopening...
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

15 years ago
*** Bug 158962 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
I can confirm that this bug persists in Mozilla 1.3 for Mac OS X. My History
sidebar is currently sorted this way:

3
Yesterday
2
Today
4
5
Older

Clicking to re-sort results in 2, 3, 4, 5, Older, Today, Yesterday.

Clicking again results in: Yesterday, Today, Older, 5, 4, 3, 2

Another click results in 5, Today, Older, Yesterday, 4, 3, 2

Comment 11

12 years ago
*** Bug 291756 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Assignee: firefox → nobody
Severity: minor → normal
OS: Windows 2000 → All
QA Contact: claudius → history.global

Comment 12

8 years ago
works for me

Comment 13

5 years ago
Checked on current trunk, sort order doesn't affect history folders, is this still actual?
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1
Build identifier: 20120918003007
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 WFM]

Comment 14

5 years ago
Resolved per whiteboard
Status: NEW → RESOLVED
Last Resolved: 15 years ago5 years ago
Resolution: --- → WORKSFORME
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 WFM] → [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.