Mozilla opens helper application as Classic, rather than Carbon, application

RESOLVED WORKSFORME

Status

Core Graveyard
File Handling
RESOLVED WORKSFORME
16 years ago
2 years ago

People

(Reporter: Erik Brakvatne, Assigned: Bill Law)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0rc3)
Gecko/20020523
BuildID:    Mozilla 1.0 Release Candidate 3

I have been trying to use Hotline 1.8.5 client to download files off the web. I
go to www.hlsearch.com to search for file to download off Hotline. I have setup
the helper so that when I click on a file or server to connect to using the
Hotline client software. A example of a link you click on www.hlsearch.com after
searching for a file or server is as follows "hotline:192.168.0.0.1" I have set
the mime type to "hotline:" and for it to open Hotline Client. It works, it
opens the server connection in Hotline Client but Mozilla choses to open Hotline
Client (Which is a Carbon application) in Classic. Once classic boots it works
fine. But I want Hotline to open in Mac OS X not Classic. This application works
fine in Mac OS X.

Reproducible: Always
Steps to Reproduce:
1.Setup the Helper Application in the Prefs. by setting the mime type of the
Helper to "hotline:" with out quotes and set it up to open in the Hotline Client
1.8.5 software (Only 1.8.5 because 1.8.5 works in Mac OS X)
2.Go to www.hlsearch.com and click on hotline
3.Click on server search or file search (which ever you perfer both will have
the same outcome)
4.If in file search find a file of your choice. or if you are in server search
click on any server name listed and it will launch Hotline in Classic, not in
Mac OS X
5.If you chose to search for a file click on the server name with the file that
you search for and it will launch Hotline in Classic, not in Mac OS X.

Actual Results:  It launches Hotline or even possibly every Carbon app in
Classic, not in Mac OS X like it is supposed to.

Expected Results:  It should launch the Carbon Helper application in Mac OS X,
not in Mac OS 9

Updated

16 years ago
Depends on: 143118

Updated

16 years ago
No longer depends on: 143118

Comment 1

15 years ago
Erik, can you still reproduce this problem using a recent nightly build?

Carbon applications have a checkbox in their Get Info window about whether to
open as Carbon or Classic applications. Is that set correctly?
Assignee: ben → law
URL: no url
Component: Preferences → File Handling
QA Contact: sairuh → petersen
Summary: Problem with Helper Applications → Mozilla opens helper application as Classic, rather than Carbon, application
ccing some people who may know what this is all about (and whether it's even a
problem in the new Mach-O world).

Comment 3

15 years ago
We're using an OS call to launch the helper app so if it's being launched in
Classic I don't think it's us.  Besides what Greg asks, the reporter should
verify there aren't multiple copies of the app on the hard drive.

Comment 4

15 years ago
Launch Services does have a flag to say if you want to launch the classic or
Carbon version of an app, IIRC.
Yes... and what are you supposed to do with that flag?

Comment 6

15 years ago
We always set them to the defaults (open, async) and AFAIK the only change we'll
make to that is add the kLSLaunchDontSwitch flag so we aren't asking for the
Classic app, that's what LaunchServices/Internet Config is telling us is the helper.
So this is a change to nsLocalFileMac, basically?  Can someone who has a mac and
can test actually take this, then?  ;)

Comment 8

15 years ago
Erik Brakvatne, can you still reproduce this problem using a current nightly build?

Comment 9

14 years ago
no other reports of this problem in past 2 years.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.