Closed Bug 1485732 Opened 3 years ago Closed 6 months ago

More clearly mark/highlight the topmost-level domains in the address bar

Categories

(Firefox :: Address Bar, enhancement, P5)

63 Branch
enhancement

Tracking

()

RESOLVED WONTFIX

People

(Reporter: pbasista, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180823100106

Steps to reproduce:

Please consider clearly marking a few topmost-level domains in the address bar, so that they can be easily distinguished from the lower-level domains.

The motivation is to avoid phishing attacks which use long domain names starting with a low-level domain name which resembles a well-known second or third level domain names, for example:
google.com.something.unrelated.tld

The original idea comes from this HN comment:
https://news.ycombinator.com/item?id=17827524
I thought that Firefox does not do this already, but I have just noticed that it actually *does* render the top level domain and the second level domain of https sites in white color and the rest of URL in grey color (on dark theme).

However, it is in my opinion not sufficient, because such a subtle difference is very easy to overlook.

Therefore, please consider making the highlighting more obvious. And also include the non-https websites, because they can become phishing targets as well.
Severity: normal → enhancement
Component: Untriaged → Address Bar
Depends on: 451833
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P5
Summary: Clearly mark the topmost-level domains in the address bar → More clearly mark/highlight the topmost-level domains in the address bar

This was brought up other times, as said we already de-emphasise the non critical part of the domain, though we don't think increasing the contrast will do much more into helping the user understand the implications. We should investigate different solutions, for example some browsers only show the relevant domain, but that has also downsides.
Short, we don't think making the difference more obvious will have a measurable effect over the current de-emphasis.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.