Closed Bug 1485950 Opened 2 years ago Closed 2 years ago

Permafailure ccov org.mozilla.geckoview.test.AccessibilityTest

Categories

(Firefox for Android :: General, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: tiberius_oros, Unassigned)

References

Details

No description provided.
Flags: needinfo?(mcastelluccio)
Flags: needinfo?(kmaglione+bmo)
This loooks fixed now, but just for the record.

https://treeherder.mozilla.org/logviewer.html#?job_id=195707192&repo=mozilla-central&lineNumber=1398

[task 2018-08-24T10:53:05.566Z] 10:53:05     INFO -  TEST-START | org.mozilla.geckoview.test.AccessibilityTest.testClipboard
[task 2018-08-24T10:54:11.600Z] 10:54:11     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: id=AndroidJUnitRunner
[task 2018-08-24T10:54:11.602Z] 10:54:11     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: current=4
[task 2018-08-24T10:54:11.603Z] 10:54:11     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: class=org.mozilla.geckoview.test.AccessibilityTest
[task 2018-08-24T10:54:11.603Z] 10:54:11     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stream=
[task 2018-08-24T10:54:11.603Z] 10:54:11     INFO -  org.mozilla.geckoview.test | Error in testClipboard(org.mozilla.geckoview.test.AccessibilityTest):
[task 2018-08-24T10:54:11.603Z] 10:54:11     INFO -  org.mozilla.geckoview.test | java.lang.RuntimeException: noTab: Unexpected error while calling getTab(): TypeError: Services.wm.getEnumerator(...) is not iterable
[task 2018-08-24T10:54:11.603Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rdp.RDPConnection$InputThread.processPacket(RDPConnection.java:124)
[task 2018-08-24T10:54:11.604Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rdp.RDPConnection.processInputPacket(RDPConnection.java:314)
[task 2018-08-24T10:54:11.604Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rdp.Actor$Reply.get(Actor.java:72)
[task 2018-08-24T10:54:11.605Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rdp.RDPConnection.getMostRecentTab(RDPConnection.java:324)
[task 2018-08-24T10:54:11.606Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitForOpenSession(GeckoSessionTestRule.java:1342)
[task 2018-08-24T10:54:11.606Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.openSession(GeckoSessionTestRule.java:1322)
[task 2018-08-24T10:54:11.606Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.prepareStatement(GeckoSessionTestRule.java:1294)
[task 2018-08-24T10:54:11.607Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule$4$1.run(GeckoSessionTestRule.java:1485)
[task 2018-08-24T10:54:11.608Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at android.app.Instrumentation$SyncRunnable.run(Instrumentation.java:1719)
[task 2018-08-24T10:54:11.608Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at android.os.Handler.handleCallback(Handler.java:730)
[task 2018-08-24T10:54:11.609Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2018-08-24T10:54:11.609Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at android.os.Looper.loop(Looper.java:137)
[task 2018-08-24T10:54:11.610Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at android.app.ActivityThread.main(ActivityThread.java:5103)
[task 2018-08-24T10:54:11.610Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invokeNative(Native Method)
[task 2018-08-24T10:54:11.611Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invoke(Method.java:525)
[task 2018-08-24T10:54:11.611Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:737)
[task 2018-08-24T10:54:11.612Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
[task 2018-08-24T10:54:11.612Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at dalvik.system.NativeStart.main(Native Method)
[task 2018-08-24T10:54:11.613Z] 10:54:11     INFO -  org.mozilla.geckoview.test | Caused by: java.lang.Exception: noTab: Unexpected error while calling getTab(): TypeError: Services.wm.getEnumerator(...) is not iterable
[task 2018-08-24T10:54:11.613Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rdp.RDPConnection$InputThread.readInputPacket(RDPConnection.java:187)
[task 2018-08-24T10:54:11.614Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rdp.RDPConnection$InputThread.run(RDPConnection.java:74)
[task 2018-08-24T10:54:11.614Z] 10:54:11     INFO -  org.mozilla.geckoview.test |
[task 2018-08-24T10:54:11.614Z] 10:54:11     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: numtests=77
[task 2018-08-24T10:54:11.615Z] 10:54:11     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stack=java.lang.RuntimeException: noTab: Unexpected error while calling getTab(): TypeError: Services.wm.getEnumerator(...) is not iterable
[task 2018-08-24T10:54:11.615Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rdp.RDPConnection$InputThread.processPacket(RDPConnection.java:124)
[task 2018-08-24T10:54:11.616Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rdp.RDPConnection.processInputPacket(RDPConnection.java:314)
[task 2018-08-24T10:54:11.617Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rdp.Actor$Reply.get(Actor.java:72)
[task 2018-08-24T10:54:11.618Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rdp.RDPConnection.getMostRecentTab(RDPConnection.java:324)
[task 2018-08-24T10:54:11.619Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitForOpenSession(GeckoSessionTestRule.java:1342)
[task 2018-08-24T10:54:11.619Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.openSession(GeckoSessionTestRule.java:1322)
[task 2018-08-24T10:54:11.620Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.prepareStatement(GeckoSessionTestRule.java:1294)
[task 2018-08-24T10:54:11.621Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rule.GeckoSessionTestRule$4$1.run(GeckoSessionTestRule.java:1485)
[task 2018-08-24T10:54:11.621Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at android.app.Instrumentation$SyncRunnable.run(Instrumentation.java:1719)
[task 2018-08-24T10:54:11.622Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at android.os.Handler.handleCallback(Handler.java:730)
[task 2018-08-24T10:54:11.622Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2018-08-24T10:54:11.623Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at android.os.Looper.loop(Looper.java:137)
[task 2018-08-24T10:54:11.623Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at android.app.ActivityThread.main(ActivityThread.java:5103)
[task 2018-08-24T10:54:11.624Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invokeNative(Native Method)
[task 2018-08-24T10:54:11.624Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at java.lang.reflect.Method.invoke(Method.java:525)
[task 2018-08-24T10:54:11.624Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:737)
[task 2018-08-24T10:54:11.625Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
[task 2018-08-24T10:54:11.625Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at dalvik.system.NativeStart.main(Native Method)
[task 2018-08-24T10:54:11.626Z] 10:54:11     INFO -  org.mozilla.geckoview.test | Caused by: java.lang.Exception: noTab: Unexpected error while calling getTab(): TypeError: Services.wm.getEnumerator(...) is not iterable
[task 2018-08-24T10:54:11.626Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rdp.RDPConnection$InputThread.readInputPacket(RDPConnection.java:187)
[task 2018-08-24T10:54:11.627Z] 10:54:11     INFO -  org.mozilla.geckoview.test | 	at org.mozilla.geckoview.test.rdp.RDPConnection$InputThread.run(RDPConnection.java:74)
[task 2018-08-24T10:54:11.627Z] 10:54:11     INFO -  org.mozilla.geckoview.test |
[task 2018-08-24T10:54:11.628Z] 10:54:11     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: test=testClipboard
[task 2018-08-24T10:54:11.628Z] 10:54:11     INFO -  org.mozilla.geckoview.test | INSTRUMENTATION_STATUS_CODE: -2
[task 2018-08-24T10:54:11.628Z] 10:54:11  WARNING -  TEST-UNEXPECTED-FAIL | org.mozilla.geckoview.test.AccessibilityTest.testClipboard | status -2
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(mcastelluccio)
Flags: needinfo?(kmaglione+bmo)
Resolution: --- → WORKSFORME
Summary: Permafailure org.mozilla.geckoview.test.AccessibilityTest → Permafailure ccov org.mozilla.geckoview.test.AccessibilityTest
You need to log in before you can comment on or make changes to this bug.