Closed Bug 1486033 Opened Last year Closed Last year

Add plumbing for Telemetry for new network process

Categories

(Toolkit :: Telemetry, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
Tracking Status
firefox63 --- affected

People

(Reporter: gfritzsche, Assigned: kershaw)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We're looking to move network operations to a separate process per bug 1322426.

To be able to get Telemetry sent out from that process, we'll need to add a bit of plumbing work to connect that process Telemetry to the parent process (similar to our content, gfx & extension process handling).
This bug goes into our backlog until the network process work stabilizes.
Priority: -- → P3
Thanks for filing this!
A straightforward patch.
1. Add telemetry IPC messages in PSocketProcess.ipdl.
2. Add socket process type in Processes.yaml.
3. Plumb the telemetry to parent process.
Assignee: nobody → kershaw
Hey kershaw, can you redirect the review to :janerik?
Flags: needinfo?(kershaw)
(In reply to Georg Fritzsche [:gfritzsche] from comment #4)
> Hey kershaw, can you redirect the review to :janerik?

sure.
Flags: needinfo?(kershaw)
Duplicate of this bug: 1430684
Status: NEW → ASSIGNED
https://hg.mozilla.org/projects/larch/rev/cf15e45abd5b5f286a9fcf6f56a8b3f55cadfe19
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.