Closed Bug 1486364 Opened Last year Closed Last year

Clicking on scrolled out expanded object updates the scroll

Categories

(DevTools :: Console, defect, P1)

defect

Tracking

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62 unaffected, firefox63 fixed)

RESOLVED FIXED
Firefox 63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

Details

(Keywords: regression)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1469959 +++

STRs:
- open console
- log an object with many properties, eg `document`
- expand the object
- scrolldown until you see `prototype`
- expand prototype

ER: prototype is expanded
AR: viewport scrolls to show the beginning of the object, prototype is not expanded

---

This is a new regression, which I think was caused by https://github.com/devtools-html/debugger.html/pull/6809. 

There was a good reason the test was failing and Bug 1484672 should not have been done (blame's on me 🤦‍♀️).
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
No longer blocks: 1463415
In https://github.com/devtools-html/debugger.html/pull/6809 a check
was removed in the Tree component because seens as unnecessary, and
a test was modified to accomodate the change. Turns out the test was
needed in its original form, and was surfacing a bug.
This patch rolls back both the change in the Tree component _and_ in
the test.
The Tree modification will be backported to the Github repository.
Comment on attachment 9004136 [details]
Bug 1486364 - Revert changes in Tree component and test; r=jdescottes.

Julian Descottes [:jdescottes][:julian] has approved the revision.
Attachment #9004136 - Flags: review+
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5ccb4b6527c1
Revert changes in Tree component and test; r=jdescottes.
https://hg.mozilla.org/mozilla-central/rev/5ccb4b6527c1
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
You need to log in before you can comment on or make changes to this bug.