The about:config "Search:" bar no longer has an outline when focused

VERIFIED FIXED in Firefox 63

Status

()

defect
P1
normal
VERIFIED FIXED
11 months ago
11 months ago

People

(Reporter: cmuresan, Assigned: MattN)

Tracking

({regression})

Trunk
mozilla63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62 unaffected, firefox63 verified)

Details

(Whiteboard: [webpayments])

Attachments

(2 attachments)

[Affected versions]:
- Nightly v63.0a1, Build ID 20180826220129

[Affected Platforms]:
- All Windows
- All Linux
- All Mac

[Steps to reproduce]:
1. Open the browser and navigate to about:config.
2. Click the "I accept the risk" button.
3. Observe the search bar.

[Expected results]:
- The search bar has a blue outline when focused.

[Actual results]:
- The search bar has no outline when focused.

[Regression range]:
Last good revision: fcae76a34c32ad73442d7440a203230c053a7649
First bad revision: f3fa1af05d494c8b363bad855e754d2c472d15af
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=fcae76a34c32ad73442d7440a203230c053a7649&tochange=f3fa1af05d494c8b363bad855e754d2c472d15af

[Notes]:
- Attached a screen recording of the issue.
From the pushlog is seems that bug 1485473 has caused this regression.

Matt, could you please take a look at this?
Flags: needinfo?(MattN+bmo)
Oops, simple mistake :(
Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Component: Form Autofill → Themes
Flags: needinfo?(MattN+bmo)
Priority: -- → P1
It was accidentally copied from the previous ruleset for the -moz-ui-invalid rules but I meant to invesigate whether -moz-ui-invalid applied to <xul:textbox> before landing.
Comment on attachment 9004307 [details]
Bug 1486413 - Revert 'xul|textbox[focused]' rule accidentally added in Bug 1486413. r=sfoster

Jared Wein [:jaws] (please needinfo? me) has approved the revision.
Attachment #9004307 - Flags: review+
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6589349f1303
Revert 'xul|textbox[focused]' rule accidentally added in Bug 1486413. r=jaws
Whiteboard: [webpayments]
Flags: qe-verify+
QA Contact: hani.yacoub
https://hg.mozilla.org/mozilla-central/rev/6589349f1303
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Duplicate of this bug: 1487014
I have verified that the issue is no longer reproducible on the latest Nightly 63.0a1 (Build ID 20180828220157) on Windows 10 x64, Mac 10.13.6 and Arch Linux x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.