Closed Bug 1486491 Opened Last year Closed Last year

mbox to maildir conversion OOM

Categories

(MailNews Core :: Backend, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1491228

People

(Reporter: darryl.hon, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36

Steps to reproduce:

Have imap mbox folder structure of aprox. 3.96GB
Set preference mail.store_conversion_enabled
Change message store type to maildir in Account Manager/Settings



Actual results:

Conversion dialog appears with progress stopping at 71%
Error console reported: Error: [Exception... "Out of Memory"  nsresult: "0x8007000e (NS_ERROR_OUT_OF_MEMORY)"  location: "JS frame :: resource:///modules/converterWorker.js :: <TOP_LEVEL> :: line 162"  data: no]


Expected results:

Completed the conversion.
Attached image maildir_conversion.png
I have the same issue. But mine stops at 0% since it is a super huge e-mail account.

It worked for smaller accounts. 

It is POP3 not IMAP.

TB goes straight to 2GB and then the error appears in the console. A 64bit version may work or something else must be done. Since Console2 and other stuff is not available I can't tell on which folder it failed.
probably same issue as bug 1491228
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Component: Untriaged → Backend
Product: Thunderbird → MailNews Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1491228
You need to log in before you can comment on or make changes to this bug.