Open Bug 1486756 Opened 3 years ago Updated 9 months ago

Layout is broken on buy.guildwars2.com while Tracking Protection Basic is enabled

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

62 Branch
x86_64
Windows 10
defect

Tracking

()

REOPENED

People

(Reporter: oanaarbuzov, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [webcompat][tp-ads][tp-yellowlist-active][tp-storefront])

User Story

digitalriver.com

Attachments

(4 files)

Attached image BrokenLayout.png
[Environment:]
Browser / Version: Firefox Nightly 63.0a1 (2018-08-27)
Operating System: Windows 10 Pro

[Prerequisites:]
    1. Tracking Protection Basic enabled.
[Steps to Reproduce:]
    1. Navigate to https://buy.guildwars2.com/store?Action=html&Locale=en_IE&SiteID=gw2&cid=104%3A5%3A%3A%3A%3AGlobal%3A289%3A%3A%3A&pbPage=pathoffire&themeID=4785548100 
    2. Observe the page.
        
[Expected Behavior:]
Layout is correctly displayed.
 
[Actual Behavior:]
Layout is broken (images, css).

[Notes:]
Also reproducible after signing into the account and navigating to 
URL: https://buy.guildwars2.com/store?Action=DisplayPage&Locale=en_IE&SiteID=gw2&id=QuickBuyCartPage
Added broken layout after sign in.
The issue is related to `trackingprotection` breakage.

Looking at the devtools console, here are the blocked resources:
The resource at “https://drh.img.digitalriver.com/DRHM/Storefront/Site/gw2/cm/multimedia/css/reset-min.css” was blocked because content blocking is enabled.
The resource at “https://drh1.img.digitalriver.com/DRHM/Storefront/Site/gw2/cm/multimedia/js/qtip2/jquery.qtip.min.js?a” was blocked because content blocking is enabled.
The resource at “https://www.googletagmanager.com/gtm.js?id=GTM-KV7FT5” was blocked because content blocking is enabled.

So below are the domains to test:
- drh.img.digitalriver.com
- drh1.img.digitalriver.com
- www.googletagmanager.com

I opened the URL in a fresh browser profile (Firefox Nightly 63, uMatrix installed, normal mode) and loaded the page. The page layout is broken.

I disabled the Spoof Referrer option in uMatrix and then WHITELISTED:
- digitalriver.com (including all related domains)
and layout is displayed correctly.

The other resource (www.googletagmanager.com) didn't help. 

So in conclusion:
- digitalriver.com is in Advertising category = [tp-ads]
Attached image uMatrixResults.png
Added uMatrix results.
Added uMatrix results after login.
Blocks: 1486781
Blocks: 1486790
No longer blocks: 1486781, 1486790
See Also: → 1486781, 1486790
Product: Tech Evangelism → Web Compatibility

Migrating Webcompat whiteboard priorities to project flags. See bug 1547409.

Webcompat Priority: --- → ?

See bug 1547409. Migrating whiteboard priority tags to program flags.

Webcompat Priority: ? → ---

This is another instance of Digital River's CDN resources being blocked, similar to the situation discussed here: https://bugzilla.mozilla.org/show_bug.cgi?id=1483201#c5

Duplicate of this bug: 1486790
Whiteboard: [webcompat][tp-ads] → [webcompat][tp-ads][tp-yellowlist-active][tp-storefront]

The issue is no longer reproducible with ETP - Standard, the layout is displayed correctly.
https://prnt.sc/x85lk3

Note: The issue still occurs with ETP - Strict.
https://prnt.sc/x85iy1

Tested with:
Browser / Version: Firefox Nightly 86.0a1 (2021-01-18)
Operating System: Windows 10 Pro

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Component: Desktop → Privacy: Anti-Tracking
Product: Web Compatibility → Core
Resolution: FIXED → ---
Version: Firefox 62 → 62 Branch
You need to log in before you can comment on or make changes to this bug.