browser.xhtml: some key shortcuts for menuitems don't work until you've opened the menu

RESOLVED FIXED in Firefox 64

Status

()

defect
P3
normal
RESOLVED FIXED
8 months ago
7 months ago

People

(Reporter: bgrins, Assigned: bdahl)

Tracking

unspecified
mozilla64
Points:
---

Firefox Tracking Flags

(firefox64 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 months ago
I noticed this at first with the Browser Console, cmd+shift+J wasn't opening it. But if I open Tools->Web Developer and then close the menu (don't click on anything), the keyboard shortcut starts to work.

Another example: cmd+opt+r doesn't reload the browser window until you open the File menu.
Hello Brian,

I have changed the bug's component to "Menus" since it's related to them and, in this case, it will probably be addressed sooner. 
On the other hand, I am trying to reproduce the issue, but I am unable. The shortcut actions work as expected.

Please try to provide some more details that you can think of, including:
1. Which browser are you using?
2. Does this issue reproduce constantly?
3. If yes, please test if the issue is reproducible in safe mode, here is a link that can help you:
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
4. Which operating system are you using?
5. Does this issue reproduce on the latest Nightly?

Thank you for your contribution!
Component: General → Menus
Flags: needinfo?(bgrinstead)
(Reporter)

Comment 2

8 months ago
(In reply to Bodea Daniel [:danibodea] from comment #1)
> Hello Brian,
> 
> I have changed the bug's component to "Menus" since it's related to them
> and, in this case, it will probably be addressed sooner. 
> On the other hand, I am trying to reproduce the issue, but I am unable. The
> shortcut actions work as expected.
> 
> Please try to provide some more details that you can think of, including:
> 1. Which browser are you using?
> 2. Does this issue reproduce constantly?
> 3. If yes, please test if the issue is reproducible in safe mode, here is a
> link that can help you:
> https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-
> mode
> 4. Which operating system are you using?
> 5. Does this issue reproduce on the latest Nightly?
> 
> Thank you for your contribution!

Hi Bodea, this is for an in-development browser mode that's not shipping to users, so it doesn't need any testing. Is there a flag we should set so bugs like this so they don't show up on your radar?
Flags: needinfo?(bgrinstead) → needinfo?(daniel.bodea)
Priority: -- → P3
Hello Brian, 

In order for your bugs not to get on our lists, you'd need to set its Product and Component when you create them; a relevant component, of course.

Thanks!
Flags: needinfo?(daniel.bodea)
(Assignee)

Comment 4

7 months ago
The global XBL key handler wasn't being setup for browser.xhtml since it
was being setup in XULDocument.

MozReview-Commit-ID: H9OGQbAGRQn
Comment on attachment 9010422 [details]
Bug 1486895 - Move keyset handling to XUL element. r=smaug

Olli Pettay [:smaug] (r- if the bug doesn't explain what the change(s) are about.) has approved the revision.
Attachment #9010422 - Flags: review+

Comment 6

7 months ago
Pushed by bdahl@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/46803eba26ad
Move keyset handling to XUL element. r=smaug

Comment 7

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/46803eba26ad
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
(Assignee)

Updated

7 months ago
Assignee: nobody → bdahl
Component: Menus → XUL
Product: Firefox → Core
Target Milestone: Firefox 64 → mozilla64
You need to log in before you can comment on or make changes to this bug.