Closed Bug 1486964 Opened 2 years ago Closed 11 months ago

Drop -moz-touch-enabled

Categories

(Core :: CSS Parsing and Computation, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox63 --- wontfix
firefox73 --- fixed

People

(Reporter: hiro, Assigned: emilio)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete, site-compat)

Attachments

(2 files)

It can be replaced by 'any-hover: hover' (or hover:hover)?
Keywords: site-compat

Modernizr 3.7.1 (March 14, 2019) includes detection for window.TouchEvent, so the legacy detection --

window.matchMedia('(-moz-touch-enabled)');

-- will someday be unnecessary on desktop (I think it's already unnecessary on mobile). However, I'm sure a lot of sites do not update Modernizr very quickly, so this will still be around for a while.

With that in mind:

If the user sets

dom.w3c_touch_events.enabled = 0

to disable touch events, unfortunately window.matchMedia('(-moz-touch-enabled)') still returns true.

This leads to a broken experience on sites where mouse support is disabled in favor of touch support. It also creates a discrepancy that can be used for fingerprinting. How can this be fixed if this media query is going to live on for a while?

Depends on: 1588737

Ideally Modernizr would be fixed. But the media query is gone in bug 1588737.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1588737

Well, this bug is for removal and Bug 1588737 is for deprecation...

Guess we can keep this open and use this bug to flip the pref in release builds.

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

This should block bug 775235 for tracking.

Yup, it's about time to toggle the pref on in release too.

Assignee: nobody → emilio
Blocks: unprefix
Status: REOPENED → ASSIGNED

We've had it disabled on Nightly with no fallout for a while, and having it
enabled breaks websites with touch screens as described in this bug and related
ones.

Given the above, let's disable it in all channels, and we'll remove the code in
the next cycle.

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8d30b15ca8f9
Disable -moz-touch-enabled in all channels. r=hiro
Status: ASSIGNED → RESOLVED
Closed: 1 year ago11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Keywords: dev-doc-needed

Added a warning on the -moz-touch-enabled page that is unsupported as of 73, and to use pointer: coarse (linked) instead.

You need to log in before you can comment on or make changes to this bug.