[PP]Linux, Crash/Hang when dismissing the Account Settings dialog

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Account Configuration
P2
major
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: Ninoschka Baca, Assigned: Alec Flett)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build 1999092409M11: Linux/Redhat 6.0

Overview: Launching the Account Settings dialog and dismissing it by selecting
the "Cancel" button can crash the application. Depending on the system it may
crash the first time or many times later:

1. Esther's Linux has a 166mhz and 64MB of ram.  When she launches the Account
Settings dialog and selects the "Cancel" button then the application crashes. If
she launches the Account Settings dialog and then launches the Account Wizard
and selects the "Next" or "Cancel" button this also results in a crash. The
console states something similar to this:

"There are 1 smtp server
initialized with nsmail-2"

2. Peter's Linux is a 200 mhz system with 160 MB of ram. He can launch the
Account Settings dialog once, select the "Cancel" button without a problem. If
he launches the Account Settings dialog a second time and selects the "Cancel"
button, the application crashes.

3. My Linux system is a 200 mhz system with 64 MB of ram. I can launch the
Account Settings dialog and select the "Cancel" button 15 times before the
application crashes.

Other Platforms:
- NT4: It does not crash.
- Mac: Unable to try with this build due to bug# 14146.
(Assignee)

Comment 1

19 years ago
are any of these migrated profiles by any chance? Peter and I have both noticed
wierdness with migrated profiles...
Status: NEW → ASSIGNED
(Assignee)

Comment 2

19 years ago
can I get some stack traces, too?
(Reporter)

Updated

19 years ago
Summary: [PP]Linux, Crash when dismissing the Account Settings dialog → [PP]Linux, Hang when dismissing the Account Settings dialog
(Reporter)

Comment 3

19 years ago
Yes, the original scenarios were migrated prefs. Unfortunately the application
hangs and no stack trace is available.

Trying to create a new account on Esther's system we:
1. start the application with "./mozilla-apprunner.sh -installer".
2. We see the list of profiles to be migrated and choose the "New" button.
3. After the list is updated with the new profile the "Start" button is selected
but it never prompts to create a new account but Navigator starts.
4. We launch Mail and notice there is a Local Mail folder.
5. Open Account Settings and it displays as expected.
6. In "Account Settings" select the "OK" button and the application hangs.
(Assignee)

Comment 4

19 years ago
I think there is a general problem with dismissing XUL dialogs in today's
build... I don't think this has much to do with the account manager.
Investigating further.
(Assignee)

Updated

19 years ago
Depends on: 15683
(Assignee)

Updated

19 years ago
Priority: P3 → P2
Target Milestone: M11
(Assignee)

Comment 5

19 years ago
ok, I think this problem has gone away. If it's still there, I'm going to
reassign to trudelle.... still waiting for my build though.
(Assignee)

Updated

19 years ago
Summary: [PP]Linux, Hang when dismissing the Account Settings dialog → [PP]Linux, Crash/Hang when dismissing the Account Settings dialog
(Assignee)

Comment 6

19 years ago
Augh, days later and I've once again found this bug while I'm waiting for my
build.
Anyway, I've really had no problems with this recently. Can someone else try
this? I have a feeling this has simply gone away.

Comment 7

19 years ago
Ok, I'll ask someone to try and update the bug.

Comment 8

19 years ago
Linux (1999-10-18-08 M11)
Win Nt 4.0 (1999-10-18-09 M11)
I tried closing Account Setup dialog by clicking the "OK", or "Cancel" buttons,
it works fine. I also click on the window close "X" button. It works fine too.
The problem is fixed on both Linux and Win_nt. Have not tried Mac yet.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 9

19 years ago
good enough for me, I'll mark worksforme

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
I am using the 10/11 Mac build (1999-10-11-14 M11) to check the bug because the
later Mac builds has problem on migration.
I check the bug using the 9/24 scenario.  I do not see it crash when clicking
OK of the Account Setup dialog.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.