all links imroperly underlined on mouse over...

RESOLVED FIXED

Status

Tech Evangelism Graveyard
Other
--
major
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: Julo, Assigned: Pavol Vaskovic)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; sk-SK; rv:1.0.0+)
Gecko/20020602
BuildID:    2002060208

If mouse is over link all links in same table become underlined (only one shud
do). I didn't see this using older builds.


Reproducible: Always
Steps to Reproduce:
1.go http://www.sme.sk
2.get mouse over some link
3.

Actual Results:  many links gets underlined

Expected Results:  only one to be underlined
Is this about the white links in the dark bar at the top?  If so, the current 
behavior is correct (and the old one was wrong).  The HTML there is:

<td class=headlineBold height=18>

with all the links in the TD.  Now the stylesheet has:

.headlineBold:hover { font-family: Verdana, Arial, Helvetica, sans-serif; 
                      font-size: 10px; 
                      color: #FFFFFF;
                      text-decoration: underline;
                      font-weight: bold;}

So when the table cell is hovered all the text in the table cell should be 
underlined.  Mozilla did not use to apply :hover correctly to things other than 
links; now it does.

Comment 2

16 years ago
Make it "a.headlineBold:hover" for the properties you want only on the links and
it'll work. Marking invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Reopening for 2 reasons:

1)  We have no confirmation that the problem I described is indeed the one the
    reporter meant.
2)  If it _is_ the same problem, this should go to evangelism.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 4

16 years ago
Described problem is not only in header of page, but on every link in front page.
But this will be probably same problem.
Yep.  I just took the page apart and all the table cells involved have that 
class assigned.

Evang.
Assignee: Matti → piskozub
Status: UNCONFIRMED → NEW
Component: Browser-General → Europe: Central
Ever confirmed: true
OS: Windows 2000 → All
Product: Browser → Tech Evangelism
QA Contact: imajes-qa → pali
Hardware: PC → All
Version: other → unspecified

Comment 6

16 years ago
-> Pavol
Assignee: piskozub → pali
QA Contact: pali → piskozub

Comment 7

16 years ago
BTW, it works for me with Mozilla 1.0
Yes.  The :hover bug we had was fixed on trunk only, not on branch.
(Assignee)

Comment 9

16 years ago
Sent e-mail to "error reporting" through their contact page.
Status: NEW → ASSIGNED
(Assignee)

Comment 10

16 years ago
They replyed that they did change the css according to my comments. Could
reporter please verify? (I have moz 1.0 release, not trunk build)
(Reporter)

Comment 11

16 years ago
No problems with 2002060208, thanks.
(Assignee)

Comment 12

16 years ago
marking fixed per comment 11
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 13

15 years ago
-> other
Component: Europe: Central → Other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.