Closed Bug 1487787 Opened 3 years ago Closed 3 years ago

Restrict usage of media autoplay by feature policy

Categories

(Core :: Audio/Video: Playback, enhancement, P3)

All
Unspecified
enhancement

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox63 --- affected

People

(Reporter: iclelland, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-needed)

Video autoplay policy can be controlled through feature policy (https://github.com/whatwg/html/pull/3829)

If the policy in the active document disallows the ‘autoplay’ feature, then the media element will not be considered eligible for autoplay.

Web Platform Tests: https://wpt.fyi/html/semantics/embedded-content/media-elements/autoplay*
(Being moved from /feature-policy/ in https://github.com/web-platform-tests/wpt/pull/12779)
Chris, do you have any thoughts on this?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(cpearce)
Priority: -- → P3
Mozilla doesn't have a public position on Feature Policy, so I filed a RFP issue [1] to resolve that. Our support of an "autoplay" feature policy would be dependent on that.

[1] https://github.com/mozilla/standards-positions/issues/102
Flags: needinfo?(cpearce)
For future reference the already existing issue is/was https://github.com/mozilla/standards-positions/issues/24

Which is actually reflected on here https://mozilla.github.io/standards-positions/ as "worth prototyping".
We now have an "intent to implement" for FP: https://groups.google.com/d/msg/mozilla.dev.platform/w3elPpZlqIE/ZA5cuKOMCAAJ

Given that, supporting autoplay in FP seems like a good idea.

FYI, we removed the autoplay feature policy in Bug 1516598 as we realised that due to our policy of a user gesture activating the entire doc tree in a tab (including across origin boundaries), that in all instances we want the gesture activation status of a doc tree to override the feature policy status.

That is, the site's setting of feature policy should never override the user's gesture activation. So for us, the autoplay feature policy has no effect, so we removed it.

For reference, the "truth table" of gesture activation/feature status/allowed to play states works out like so:

tab gesture activated autoplay feature policy status allowed to play
activated allowed true
not activated not allowed false
activated not allowed true
not activated allowed false

This may be different in other browsers with a different activation model, and if we change our activation model it may come to make sense in future, but with our current model it doesn't make sense for us to support this.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.