Closed Bug 148779 Opened 19 years ago Closed 19 years ago

<input type="file"> with css width and height renders wrong (file upload)

Categories

(Core :: Layout: Form Controls, defect)

x86
Windows 2000
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 52500

People

(Reporter: matthias.redl, Assigned: rods)

Details

Attachments

(2 files)

An input that has a stylesheet applied, like below

<INPUT NAME="paperfile" TYPE="file" class="Input300x19">

where the stylesheet defines width and height:

<style type="text/css">
<!--
.Input300x19 {  height: 19px; width: 300px}
-->
</style>

looks totally weird. The button is positioned incorrectly, the width doesn't fit.
sorry, the first gif had only 2 colors
That's because the input does not exactly fit in the CSS box model....



*** This bug has been marked as a duplicate of 52500 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.