Don't WaitForBufferOwnership if the surface is already Available.

RESOLVED FIXED in Firefox 63

Status

()

RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: imanol, Assigned: imanol)

Tracking

unspecified
mozilla63
Unspecified
Android
Points:
---

Firefox Tracking Flags

(firefox63 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 months ago
There is an assertion failure when doing dynamic canvas resized during WebVR. It can be reproduced with this sample: https://webvr.info/samples/test-slow-render.html?standardSize=1&renderScale=1.0&canvasResizeInterval=33

The problem is that WaitForBufferOwnership is called when not needed (the surface is already available)
Comment on attachment 9005673 [details]
Bug 1487825 - Don't WaitForBufferOwnership if the surface is already Available

Jeff Gilbert [:jgilbert] has approved the revision.
Attachment #9005673 - Flags: review+
(Assignee)

Updated

7 months ago
Assignee: nobody → imanol
(Assignee)

Updated

7 months ago
Keywords: checkin-needed

Comment 3

7 months ago
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1b09c0419d13
Don't WaitForBufferOwnership if the surface is already Available r=jgilbert
Keywords: checkin-needed

Comment 4

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/1b09c0419d13
Status: NEW → RESOLVED
Last Resolved: 7 months ago
status-firefox63: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
You need to log in before you can comment on or make changes to this bug.