Support adding and removing languages from the requested list

RESOLVED FIXED in Firefox 63

Status

()

defect
P1
normal
RESOLVED FIXED
11 months ago
10 months ago

People

(Reporter: mstriemer, Assigned: mstriemer)

Tracking

(Blocks 1 bug)

unspecified
Firefox 64
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox63 fixed, firefox64 fixed)

Details

Attachments

(5 attachments)

In the language alternatives dialog a user should be able to move installed languages between the requested and available lists.
Priority: -- → P3
Assignee: nobody → mstriemer
Here's a video of how it works. Disabled language packs are still ignored.

I also just noticed it still needs some minor CSS tweaks, I'll update the patch tonight/tomorrow with that.
Attachment #9006398 - Attachment description: Bug 1488467 - Support adding and removing installed browser languages r?jaws,zbraniecki → Bug 1488467 - Part 1: Support adding and removing installed browser languages r?jaws,zbraniecki
CSS is updated, here are some new screenshots.
Priority: P3 → P1
A small source of confusion that I observed so far in the conversation about this UI is about handling edge cases where a locale is added, but doesn't work, or gets disabled, or becomes unavailable for another reason.

I think the source of confusion comes from the difference between adding/ordering/removing *language packs* vs. adding/ordering/removing *requested locales*.

The difference feels subtle, and I completely understand why we want to avoid forcing such detail onto the user, but unfortunately pretending that they're directly operating on existing locales rather than requested has its consequences exactly when such edge cases happen.

I consulted the MacOS UI for language selection and noticed that they use the vocabulary about "preferred locales". It doesn't seem random. It seems like they try to communicate to the user, in a gentle way, that what the user is operating on is their preference, not the result of that preference against available resources.

I'm wondering if maybe we could try to fine-tune wording/UX to better reflect that reality and avoid people reporting that "I added X and it doesn't work". Because it sometimes won't. So if the narrative is "I requested X and it doesn't work", and that matches the reality better.
Comment on attachment 9006398 [details]
Bug 1488467 - Part 1: Support adding and removing installed browser languages r?jaws,zbraniecki

Jared Wein [:jaws] (please needinfo? me) has approved the revision.
Attachment #9006398 - Flags: review+
Comment on attachment 9006581 [details]
Bug 1488467 - Part 2: Match web languages dialog with browser dialog r?jaws

Jared Wein [:jaws] (please needinfo? me) has approved the revision.
Attachment #9006581 - Flags: review+
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d3ef1330cf04
Part 1: Support adding and removing installed browser languages r=jaws
https://hg.mozilla.org/integration/autoland/rev/97384d72b069
Part 2: Match web languages dialog with browser dialog r=jaws
https://hg.mozilla.org/mozilla-central/rev/d3ef1330cf04
https://hg.mozilla.org/mozilla-central/rev/97384d72b069
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Comment on attachment 9006581 [details]
Bug 1488467 - Part 2: Match web languages dialog with browser dialog r?jaws

We'd like to test the multilingual interface in Beta/Release 63 before enabling in 64 since it has parts that don't work in Nightly. This will be required for future patches to land.

Approval Request Comment
[Feature/Bug causing the regression]: None
[User impact if declined]: None
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: No
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]:None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Behind a disabled pref
[String changes made/needed]: None
Attachment #9006581 - Flags: approval-mozilla-beta?
Comment on attachment 9006581 [details]
Bug 1488467 - Part 2: Match web languages dialog with browser dialog r?jaws

Low risk for 63 as this is behind a pref,  uplift approved for 63 beta 7.

Mark, I am supposing that you meant to uplift both part 1 and 2 of the patch, not just part 2 on which you requested the uplift, can you confirm please? Thanks.
Flags: needinfo?(mstriemer)
Attachment #9006581 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Yes, both parts, please!
Flags: needinfo?(mstriemer)
(In reply to Mark Striemer [:mstriemer] from comment #11)
> [Is this code covered by automated tests?]: Yes
> [Needs manual test from QE? If yes, steps to reproduce]: No

Marking this as qe-verify- per Mark's assessment on manual testing needs and its automated coverage.
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.