Closed Bug 1488502 Opened 2 years ago Closed 2 years ago

[remote-dbg-next] Disable service worker debugging if multi e10s is enabled

Categories

(DevTools :: about:debugging, enhancement, P1)

enhancement

Tracking

(firefox66 fixed)

RESOLVED FIXED
Firefox 66
Tracking Status
firefox66 --- fixed

People

(Reporter: jdescottes, Assigned: ladybenko)

References

(Blocks 1 open bug)

Details

(Whiteboard: old-remote-debugging-ng-m3)

Attachments

(2 files)

Service worker debugging is not working properly if multi e10s is enabled. For now we should simply disable the impacted debugging features (see current about:debugging).

Depending on the status of service-workers and multi-e10s when we ship this new UI, we might look into showing a warning message etc...
Priority: P5 → P3
No longer blocks: remote-debugging-ng-m1
filter on remote-debugging-next-move-m3-to-m2
filter on remote-debugging-next-move-m3-to-m2
filter on remote-debugging-next-move-m3-to-m2
No longer blocks: remote-debugging-ng-m3
Priority: P3 → P2
Whiteboard: old-remote-debugging-ng-m3
Assignee: nobody → balbeza
Status: NEW → ASSIGNED
Priority: P2 → P1
Blocks: 1500391
Keywords: leave-open
Pushed by balbeza@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/db4022f9a4d7
Disable service workers debugging when in multi e10s. r=jdescottes,daisuke
Keywords: leave-open
Pushed by balbeza@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/392036709e44
[part 2] add test to check that service workers debugging is disabled in multi e10s. r=jdescottes,daisuke
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
You need to log in before you can comment on or make changes to this bug.