Closed Bug 1488874 Opened Last year Closed Last year

Notification channels string changes

Categories

(Firefox for Android :: General, enhancement)

All
Android
enhancement
Not set

Tracking

()

RESOLVED FIXED
Firefox 65
Tracking Status
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- fixed

People

(Reporter: JanH, Assigned: JanH)

References

Details

Attachments

(5 files)

There are some notification channels we might want to rename, see bug 1479532 and bug 1486432 for more details.
See especially bug 1479532 comment 24 and bug 1479532 comment 27.
Flags: needinfo?(brjones)
Can someone pls confirm these are the "working" strings:

* Browser
* Location service
* Downloads
* Sound and video
* App updates
* Synced tabs
* Permission alerts

If so, these look good to me.
Thanks, Brian, for confirming the strings I’ve came up with!

Jan can confirm whether these strings have fulfilled the bug’s requirement, or whether we need more (I was sure to be exhaustive, but may have overlooked a channel!)
Flags: needinfo?(jh+bugzilla)
There's still the Leanplum channel (which currently trades as "&brandShortName; Push notifications") left, compare bug 1479532 comment 27. Other than that the above list indeed covers everything.
Flags: needinfo?(jh+bugzilla)
Hi Brian, here’s a little background information that may help you write the right copy for the Leanplum channel.

Leanplum started with the assumption that users who have performed these actions will have increased daily usage and retention:

* Changed default browser to Firefox
* Installed add-ons
* Used sync to sync 2 or more devices
* Used “above the bare minimum” features, such as Bookmarks
* Customised settings, like changing search engine
* Used another Firefox app, such as Focus or Firefox for Desktop

To encourage these actions, the Leanplum program was designed to deliver messages in the product that promotes these actions.

In other words, they’re just like “Home screen tips” in Firefox Focus – except they may show up in other pages.

In desktop, we call these messages “Snippets”. On mobile, we’ve got a few options:

* Replicate the description of “Snippets” found on desktop. Ie. “Updates from Mozilla and Firefox”
* Follow Firefox Focus nomenclature and use “Tips”. E.g. “Tips and tricks”
* Write our own string. E.g.. “Mozilla and Firefox Products and services”

There’s only one small constraint: when seen alongside strings from other channels on comment 2, the channel name for Leanplum has to harmonise.

In a minute, I’ll upload a few examples of how these channels look in other apps, and how it looks in Firefox for Android.

Hope this information helps?
Assignee: nobody → jh+bugzilla
I might drop the "Permission alerts" channel for now, as I'm no longer quite as convinced that we currently really need a completely separate channel for that and we already had to add yet another channel for web site push notifications instead.
Flags: needinfo?(brjones)
(In reply to Bram Pitoyo [:bram] from comment #5)
> * Replicate the description of “Snippets” found on desktop. Ie. “Updates
> from Mozilla and Firefox”
> * Follow Firefox Focus nomenclature and use “Tips”. E.g. “Tips and tricks”
> * Write our own string. E.g.. “Mozilla and Firefox Products and services”

Personally, I'd go for "&vendorShortName; tips and tricks", then.
The media and default channels are changed as per comment 2 of this bug.
I'm keeping the location service string as it is, though, as our settings UI
uses "&vendorShortName; Location Service" as well.
I'm not exactly sure why you chose me to review these strings.

These are changes that should be reviewed by Fennec developers in the first place. 
If you need l10n feedback, please ask :delphine, since she's the person in charge of mobile projects.
Flags: needinfo?(jh+bugzilla)
I'm no longer sure myself, sorry for the confusion.
Flags: needinfo?(jh+bugzilla)
Attachment #9022282 - Attachment description: Bug 1488874 - Part 1: Fix notes. r?flod → Bug 1488874 - Part 1: Fix notes. r?nalexander
Attachment #9022283 - Attachment description: Bug 1488874 - Part 2: Notification channel name changes. r?flod → Bug 1488874 - Part 2: Notification channel name changes. r?nalexander
Pushed by mozilla@buttercookie.de:
https://hg.mozilla.org/integration/autoland/rev/a18675248eb6
Part 1: Fix notes. r=nalexander
https://hg.mozilla.org/integration/autoland/rev/4aeb1d183e95
Part 2: Notification channel name changes. r=nalexander
https://hg.mozilla.org/mozilla-central/rev/a18675248eb6
https://hg.mozilla.org/mozilla-central/rev/4aeb1d183e95
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
You need to log in before you can comment on or make changes to this bug.