Closed Bug 1488904 Opened Last year Closed Last year

Enable multiselect tabs feature on early beta builds

Categories

(Firefox :: Tabbed Browser, enhancement)

enhancement
Not set

Tracking

()

VERIFIED FIXED
Firefox 64
Tracking Status
firefox63 --- fixed
firefox64 --- verified

People

(Reporter: jaws, Assigned: jaws)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We'd like to get more testing on the multiselect tabs feature, which we are planning to ship with Firefox 64.

The feature is mostly implemented in Firefox 63 but we held it back from shipping in 63 due to some remaining work regarding accessibility as well as bookmarking and send-to-device.
Comment on attachment 9006688 [details]
Bug 1488904 - Enable the multiselect tabs feature on early beta builds and earlier. r?Gijs

:Gijs (he/him) has approved the revision.
Attachment #9006688 - Flags: review+
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d71560291336
Enable the multiselect tabs feature on early beta builds and earlier. r=Gijs
https://hg.mozilla.org/mozilla-central/rev/d71560291336
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Comment on attachment 9006688 [details]
Bug 1488904 - Enable the multiselect tabs feature on early beta builds and earlier. r?Gijs

Approval Request Comment
[Feature/Bug causing the regression]: new feature, would like to get expanded testing during early betas
[User impact if declined]: none
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: This feature was on Nightly for most of 63 cycle but it was held back from shipping in 63 due to some extra feature work and accessibility bugs. Those bugs are either fixed or should be fixed soon for 64 but enabling this on early betas of 63 will give us more testing and feedback before it releases with 64.
[String changes made/needed]: none
Attachment #9006688 - Flags: approval-mozilla-beta?
Comment on attachment 9006688 [details]
Bug 1488904 - Enable the multiselect tabs feature on early beta builds and earlier. r?Gijs

Uplift approved for 63 beta 5
Attachment #9006688 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Hello all,

Confirming as verified fixed  that the feature was present on all the recent beta releases including Beta 64.0b12.

Verified on Win10x 64, Ubuntu 16.04 and macOS 10.12.6.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.