tabs.create and windows.create should open about:privatebrowsing instead of about:newtab in PB

VERIFIED FIXED in Firefox 64

Status

enhancement
P1
normal
VERIFIED FIXED
8 months ago
5 months ago

People

(Reporter: robwu, Assigned: robwu)

Tracking

(Blocks 1 bug)

unspecified
mozilla64
Dependency tree / graph

Firefox Tracking Flags

(firefox64 verified, firefox65 verified)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

8 months ago
While testing bug 1393570 I found that new windows and new tabs default to about:newtab even in private browsing mode.

When the window is in private browsing mode, the default should be about:privatebrowsing. This expected behavior is the case when a new private tab/window is opened manually by the user.
That's strange, because I notice new windows opening with about:privatebrowsing in tests I've done for bug 1345474.
on second thought, I might not using webext apis to open windows.
Priority: -- → P1
(Assignee)

Comment 3

7 months ago
This is actually a regression, and should be fixed before Beta is promoted to stable.

...and windows.create for non-private browsing windows should be about:home (but that is not a regression).
https://phabricator.services.mozilla.com/D4929#inline-20894
(Assignee)

Updated

7 months ago
Blocks: 1393570
(Assignee)

Comment 4

7 months ago
I'm mistaken, this is not a regression. Unlike windows.create, tabs.create does not use newTabService.

The default hoempage of windows.create is still broken though, both for private and non-private windows.
(Assignee)

Comment 5

7 months ago
Use a homepage URL instead of a new tab URL by default in
browser.windows.create.
(Assignee)

Updated

7 months ago
Iteration: --- → 64.2 (Sep 28)
Comment hidden (obsolete)
Attachment #9015851 - Attachment is obsolete: true

Comment 7

7 months ago
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/c844033d55eb
Use about:home / about:privatebrowsing in windows.create r=rpl,dao
(Assignee)

Updated

7 months ago
Flags: needinfo?(rob)

Comment 9

7 months ago
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/cf62153b17ad
Use about:home / about:privatebrowsing in windows.create r=rpl,dao

Comment 10

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/cf62153b17ad
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64

Comment 11

6 months ago
Verified that the issue is no longer occurring on: FF 64.0b3, Nightly 65.0a1 running on Windows 10 x64, using both browser's controls and tab management extensions.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.