tscrollx's iframe.svg doesn't handle async scrolls

RESOLVED DUPLICATE of bug 1449634

Status

()

enhancement
RESOLVED DUPLICATE of bug 1449634
10 months ago
10 months ago

People

(Reporter: mattwoodrow, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox64 affected)

Details

Reporter

Description

10 months ago
APZ scrolling appears to be entirely broken on this page, using my mousewheel or keyboard, nothing moves.

This causes the talos test tscrollx to report 0 for this subtest, since it never moves.

Scrolling using the scrollbar seems to work fine.
Reporter

Comment 1

10 months ago
My understanding is that SVG gets drawn into a blob image, and we assume that the whole image scrolls together. I think that means that APZ will think that scroll events should be directed to the root scroll frame, which isn't scrollable, and nothing happens.

This page has a <foreignObject> element, with a scrollable iframe within that, so things don't work.

I'm not sure if we can easily have proper handling for content within a blob, so maybe we need to add to APZs 'dispatch to content' region for the blob if it contains foreignObject (or content with a different ASR?).
Reporter

Comment 3

10 months ago
This is the same as bug 1449634
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1449634
You need to log in before you can comment on or make changes to this bug.