Closed Bug 1489119 Opened 2 years ago Closed 2 years ago

Crash in std::_Xbad_function_call

Categories

(Toolkit :: Crash Reporting, defect)

x86
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1463048
Tracking Status
firefox63 --- unaffected
firefox64 --- fixed

People

(Reporter: marcia, Unassigned)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-1668cf75-a014-45ca-8aba-516460180906.
=============================================================

Seen while looking at nightly crash stats - unsure if this is the correct component: https://bit.ly/2wJSNeL. Windows crashes started using 20180905123750. 

Possible regression range based on build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7d542c1d11cd71d29efae6743780254d1db7c203&tochange=26990836dc5cc3cd1b8027392b79210e71094dc3

Crash reason for all crashes is Unhandled C++ Exception

Top 10 frames of crashing thread:

0 kernelbase.dll RaiseException 
1 vcruntime140.dll _CxxThrowException f:\dd\vctools\crt\vcruntime\src\eh\throw.cpp:131
2 msvcp140.dll std::_Xbad_function_call f:\dd\vctools\crt\crtw32\stdcpp\xthrow.cpp:42
3 xul.dll std::_Func_class<void, bool>::operator 
4 xul.dll void std::_Func_impl_no_alloc<`lambda at z:/build/build/src/toolkit/crashreporter/nsExceptionHandler.cpp:3868:36', void>::_Do_call 
5 xul.dll nsresult mozilla::detail::RunnableFunction<std::function<void  xpcom/threads/nsThreadUtils.h:564
6 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1161
7 xul.dll NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:519
8 xul.dll mozilla::ipc::MessagePump::Run ipc/glue/MessagePump.cpp:97
9 xul.dll MessageLoop::RunHandler ipc/chromium/src/base/message_loop.cc:318

=============================================================
Presumably this was from bug 1463048.
See Also: → 1488827
15 crashes/10 installs in the last 7 days in 64 nightly.
ni on gsvelto@mozilla.com based on Comment 1.
Flags: needinfo?(gsvelto)
Yeah, the offending patch has already been backed out and there's a proper fix waiting for review for bug 1463048.
Flags: needinfo?(gsvelto)
Looks like this is a dupe of bug 1463048
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1463048
You need to log in before you can comment on or make changes to this bug.