Make entryheader a separate template.

RESOLVED FIXED in Bugzilla 2.16

Status

()

Bugzilla
Administration
P2
normal
RESOLVED FIXED
16 years ago
5 years ago

People

(Reporter: CodeMachine, Assigned: CodeMachine)

Tracking

({regression})

2.17
Bugzilla 2.16
regression

Details

Attachments

(1 attachment)

(Assignee)

Description

16 years ago
Similar to splitting out bannerhtml, entryheaderhtml should be split out too
which is a regression also.

I can go ahead and do a patch for this, but there is a slight difference -
entryheaderhtml is blank by default.  Do I make the default a blank template, or
do I make there be no template and somehow tell TT to only include it if it
exists?
(Assignee)

Updated

16 years ago
Keywords: regression
Priority: -- → P2
Target Milestone: --- → Bugzilla 2.16
"This is some text to present to users when they report a bug.  You can edit it
in template/en/default/blah/blah."

That'll pretty much force them to customize it though :-)

Although I seem to remember seeing a bug somewhere about making that specific
per-product, which would seem to preclude having it in a template, since it
would need to be part of the product definition in the database.
(Assignee)

Comment 2

16 years ago
I think I wrote that bug, we wanted a different entryheaderhtml for webtools or
bugzilla.  But I also think that templates are better.  A template can be
product specific, and also user specific.
OK, so how do you make the template product-specific?  It contains nothing but a
variable display command?  If so, then what's the point of a separate template?
 Just put the variable display into the enter_bug template
(Assignee)

Comment 4

16 years ago
Using IF statements, there will be a comment about this in the forthcoming
patch.
have at it.  I plead ignorance.  ;)
Assignee: justdave → matty
QA Contact: matty → justdave
(Assignee)

Comment 6

16 years ago
Created attachment 86191 [details] [diff] [review]
Fix.  Includes a default comment pointing to guidelines, mostfreq and search.
(Assignee)

Comment 7

16 years ago
Adding Gerv in case he has any objections to linking to mostfreq by default.

Comment 8

16 years ago
Comment on attachment 86191 [details] [diff] [review]
Fix.  Includes a default comment pointing to guidelines, mostfreq and search.

>+Before reporting a bug, please read the <a href="bugwritinghelp.html">
>+bug writing guidelines</a>, please look at the list of
>+<a href="duplicates.cgi">most frequently reported bugs</a>, and please
>+<a href="query.cgi">search</a> for the bug.

There are quite many pleases here, are the really all necessary? :-)
I'd change the last link text to something like "search for previous
reports about this issue", because Bugzilla newcomers may not understand
how they could search for the bug they're just about to file.

Consider the above comments and act on them if you so decide, 
r=jouni anyway.
Attachment #86191 - Flags: review+

Updated

16 years ago
Keywords: patch, review
Comment on attachment 86191 [details] [diff] [review]
Fix.  Includes a default comment pointing to guidelines, mostfreq and search.

>   <tr>
>     <td></td>
>     <td colspan="3">
>-      Before filling this in, please read the
>-      <a href="bugwritinghelp.html">bug-writing guidelines</a>.
>+    [%# Migration note: The following file corresponds to the old Param
>+      # 'entryheaderhtml'
>+      #%]
>+    [% INCLUDE 'bug/create/user-message.html.tmpl' %]
>     </td>
>   </tr>

If the user-message is the only thing in the surrounding table,
the table should be part of the user-message template.

>+Before reporting a bug, please read the <a href="bugwritinghelp.html">
>+bug writing guidelines</a>, please look at the list of
>+<a href="duplicates.cgi">most frequently reported bugs</a>, and please
>+<a href="query.cgi">search</a> for the bug.

Enclose this in <p> tags?

I have no objection to linking to duplicates.cgi by default. Note that
the simple version of this entry form actually includes it in an
IFRAME.

Gerv
Attachment #86191 - Flags: review-
(Assignee)

Comment 10

16 years ago
> If the user-message is the only thing in the surrounding table,
> the table should be part of the user-message template.

Uhhh ... but it isn't the only thing.  This was done to get it aligned in a
specific way I assume ... didn't you do the bug entry template?

>> +Before reporting a bug, please read the <a href="bugwritinghelp.html">
> Enclose this in <p> tags?

I considered it but I don't see the necessity.  You wouldn't normally put <p>s
in tables unless there are multiple paragraphs ... to my understanding the <p>s
become implicit in this situation.
Comment on attachment 86191 [details] [diff] [review]
Fix.  Includes a default comment pointing to guidelines, mostfreq and search.

r=gerv, then :-)

Gerv
Attachment #86191 - Flags: review- → review+
Ready for check-in, Matty...
(Assignee)

Comment 13

16 years ago
Can't a guy get some sleep around here?
(Assignee)

Comment 14

16 years ago
HEAD

Checking in template/en/default/bug/create/create.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/create/create.html.tmpl,v 
<--  create.html.tmpl
new revision: 1.9; previous revision: 1.8
done
RCS file:
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/create/user-message.html.tmpl,v
done
Checking in template/en/default/bug/create/user-message.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/create/user-message.html.tmpl,v 
<--  user-message.html.tmpl
initial revision: 1.1
done

2.16 BRANCH

Checking in template/en/default/bug/create/create.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/create/create.html.tmpl,v 
<--  create.html.tmpl
new revision: 1.6.2.3; previous revision: 1.6.2.2
done
Checking in template/en/default/bug/create/user-message.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/create/user-message.html.tmpl,v 
<--  user-message.html.tmpl
new revision: 1.1.2.1; previous revision: 1.1
done
(Assignee)

Comment 15

16 years ago
And resolve the bug ...
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
QA Contact: justdave → default-qa
You need to log in before you can comment on or make changes to this bug.