Closed Bug 14892 Opened 21 years ago Closed 21 years ago

[PP] Mac/Linux don't silent migrate single profile

Categories

(Core Graveyard :: Profile: BackEnd, defect, P3)

x86
Windows 98
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: fenella, Assigned: sspitzer)

Details

Win32 (1999-09-24-09 m11)
STeps:
1. Setup a single profile using Nova 4.7
2. Remove mozregistry.dat file
3. From Start, select Run, type:
   "C:\Program Files\Netscape\Seamonkey\x86rel\apprunner.exe" -installer
4. Click OK
Actual result: The profile migration dialog comes up and automatically creates a
user called default. It does not prompt me the Profile and Migration dialog like
Linux and Mac do. This disallow me to see what profile name I am migrating.
Expected result: I expect the Profile and Migration dialog to come up and allow
me to select the profile name even if it is a single profile.

Linux and Mac:  This problem do not occur.
Assignee: ssu → selmer
this looks like a Steve Elmer thing.  Reassigning to him.
Product: MailNews → Browser
Wrong product.
Assignee: selmer → racham
Component: Install Wizard → Profile Manager
Summary: No Profile and Migration dialog is displayed in single profile → [PP] Mac/Linux don't silent migrate single profile
Sorry folks, you've got it backwards.  Silent migration is the desired feature
since most of our actual users don't work in QA and don't know or want to know
about profiles.  They expect this stuff to just work.

Changed summary to reflect actual problem.

The real bug here is that Mac/Linux profile migration was turned on without
making silent migration of a single profile work the same as it does on
Windows.  Seth did that work, but he didn't consult with us on this point.
Assignee: racham → sspitzer
Seth, for activation, it is important that we automatically migrate if there is
exactly one old profile and no new profiles.  We need this on all platforms
where we're doing migration and activation.
Status: NEW → ASSIGNED
Until I can fix the crashers / problems with migration, I'd rather not turn
auto-migration on.

when things are stable on all three platforms, it's a simple 1 line fix to turn
it on.

accepting.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
fixed.

now, if you have one unmigrated 4.x profile and zero 5.0 profile, and you run
-installer (or "Mozilla Installer" on the mac) it automatically does the
migration and DOESN't launch the profile manager.
I should have added that now all three platforms behave like this.
Status: RESOLVED → VERIFIED
builds 1999101508
Target Milestone: M11
Component: Profile Manager → Profile Manager BackEnd
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.