Closed Bug 1489224 Opened Last year Closed Last year

[remote-dbg-next] Tests: check that devices list shows "No device discovered" if empty

Categories

(DevTools :: about:debugging, enhancement, P1)

enhancement

Tracking

(firefox64 fixed)

RESOLVED FIXED
Firefox 64
Tracking Status
firefox64 --- fixed

People

(Reporter: jdescottes, Assigned: jdescottes)

References

Details

Attachments

(3 files)

Check that the devices list shows a message when no devices are available, and that the message disappears if devices are added.
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Comment on attachment 9010663 [details]
Bug 1489224 - Fix order of tests in aboutdebugging-new;r=daisuke

Daisuke Akatsuka (:daisuke) has approved the revision.
Attachment #9010663 - Flags: review+
Comment on attachment 9010662 [details]
Bug 1489224 - Add mochitest to check runtimes section of aboudebugging sidebar;r=daisuke

Daisuke Akatsuka (:daisuke) has approved the revision.
Attachment #9010662 - Flags: review+
Attachment #9010662 - Attachment description: Bug 1489224 - Add mochitest to check that no-devices message is displayed;r=daisuke → Bug 1489224 - Add mochitest to check runtimes section of aboudebugging sidebar;r=daisuke
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6300cdbc0e04
Fix order of tests in aboutdebugging-new;r=daisuke
https://hg.mozilla.org/integration/autoland/rev/d414a44d8119
Add mochitest to check runtimes section of aboudebugging sidebar;r=daisuke
https://hg.mozilla.org/mozilla-central/rev/6300cdbc0e04
https://hg.mozilla.org/mozilla-central/rev/d414a44d8119
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Priority: P3 → P1
Status: RESOLVED → REOPENED
Flags: needinfo?(jdescottes)
Resolution: FIXED → ---
It seems this new test leaks on windows when running in test-verify only. Both the runs from autoland and central seem to confirm this.

When looking at the test-verify logs, the test passes the first phase successfully (tests running in the same browser), but fails at the first iteration of the second phase:

16:09:46     INFO -  TEST-INFO | checking window state
16:09:46     INFO -  Browser Chrome Test Summary
16:09:46     INFO -  	Passed: 33
16:09:46     INFO -  	Failed: 1
16:09:46     INFO -  	Todo: 0
16:09:46     INFO -  	Mode: e10s
[...]
16:09:46     INFO - ::: 1. Run each test 10 times in one browser. : Pass
16:09:46     INFO - ::: 2. Run each test 5 times in a new browser each time. : FAIL

Consistent results for the 4 TV jobs that failed, "Passed: 33, Failed: 1" means the leak check failed exactly after the first test of the second phase, since the test only contains 3 asserts.

Maybe what happens is that the browser is killed too fast and the destroy of the page doesn't have time to complete (since it is async)
I can't seem to reproduce this on try in isolation: https://treeherder.mozilla.org/#/jobs?repo=try&selectedJob=201132195&revision=e6618c69a91c3eb0cb55812140ff38e16408af44

The autoland TV job only had this test running. Will move on the autoland changeset to see if I can reproduce on try there.
Status: REOPENED → ASSIGNED
> I can't seem to reproduce this on try in isolation

After rebasing the test on a more recent changeset, I managed to get the same failure on try.

This actually affects all the new about:debugging tests. I tried re-running our first initial test on try with test-verify and it fails in the same way. 

So something happened between https://hg.mozilla.org/try/rev/8265be8d02b0 and https://hg.mozilla.org/integration/autoland/rev/35c033207fa3 that makes our tests fail.
It looks like this started failing with the first changeset for USB devices:

https://hg.mozilla.org/try/rev/8ac3f47057c4
Using await check() to see if ADB is running is causing aboutdebugging to
leak on debug windows test-verify.

Ultimately we should be able to call ADB scanner without worrying if
the addon is installed or not but for now we should keep things simple
and only start the scanner if the extension is available.
Comment on attachment 9011541 [details]
Bug 1489224 - Enable adb scanner only if addon status is installed;r=daisuke

Daisuke Akatsuka (:daisuke) has approved the revision.
Attachment #9011541 - Flags: review+
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/26719c685fd3
Enable adb scanner only if addon status is installed;r=daisuke
https://hg.mozilla.org/integration/mozilla-inbound/rev/a581d5bc795d
Fix order of tests in aboutdebugging-new;r=daisuke
https://hg.mozilla.org/integration/mozilla-inbound/rev/573a32cebe76
Add mochitest to check runtimes section of aboudebugging sidebar;r=daisuke
You need to log in before you can comment on or make changes to this bug.