Closed Bug 1489250 Opened Last year Closed Last year

Crash when turning off a11y during auto-fill

Categories

(GeckoView :: General, defect, P1)

All
Android
defect

Tracking

(geckoview62+ fixed, firefox-esr60 unaffected, firefox62- unaffected, firefox63+ verified, firefox64 fixed)

RESOLVED FIXED
mozilla64
Tracking Status
geckoview62 + fixed
firefox-esr60 --- unaffected
firefox62 - unaffected
firefox63 + verified
firefox64 --- fixed

People

(Reporter: jchen, Assigned: jchen)

References

Details

Attachments

(1 file)

If GV loads a page with a11y initially on, auto-fill will initialize. However, we will then crash if a11y is subsequently turned off.
Don't send window changed event if a11y has been turned off in the mean
time.
Comment on attachment 9007026 [details]
Bug 1489250 - Don't send window changed event if a11y is off; r?eeejay

Eitan Isaacson [:eeejay] has approved the revision.
Attachment #9007026 - Flags: review+
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8a0494308f1f
Don't send window changed event if a11y is off; r=eeejay
[Tracking Requested - why for this release]:

Jim, do we need to uplift this crash fix to Fennec 62? Or does this autofill code only affect GV?
Yeah we should uplift it to Fennec 63.
[Tracking Requested - why for this release]:

This is a regression in Fennec (and GeckoView) 62.

Does this crash necessitate a 62.0.1 dot release? Or being a ride-along fix if there is a dot release for another bug?
https://hg.mozilla.org/mozilla-central/rev/8a0494308f1f
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
(In reply to Jim Chen [:jchen] [:darchons] from comment #5)
> Yeah we should uplift it to Fennec 63.

Can you prepare the patch and request the uplift please? Thanks
Flags: needinfo?(nchen)
Bug 1330257 never got uplifted to Fennec 62, so I'm having a hard time understanding why it's marked as affected.
Flags: needinfo?(cpeterson)
Yeah it should GV 62 and Fennec 63 (but not Fennec 62)
Flags: needinfo?(nchen)
Comment on attachment 9007026 [details]
Bug 1489250 - Don't send window changed event if a11y is off; r?eeejay

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1330257
[User impact if declined]: Rare crash when using auto-fill and turning a11y on/off
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Simple crash fix
[String changes made/needed]: None
Attachment #9007026 - Flags: approval-mozilla-beta?
FYI, this grafts cleanly to Beta and the GV62 relbranch as-landed. Just needs approval requests.
Flags: needinfo?(cpeterson)
Comment on attachment 9007026 [details]
Bug 1489250 - Don't send window changed event if a11y is off; r?eeejay

[Approval Request Comment]

If this is not a sec:{high,crit} bug, please state case for consideration: Crash fix

User impact if declined: Rare crash when using auto-fill and turning a11y on/off

Fix Landed on Version: 64

Risk to taking this patch (and alternatives if risky): No risk; simple crash fix

String or UUID changes made by this patch: None

See https://wiki.mozilla.org/Release_Management/Uplift_rules for more info.
Attachment #9007026 - Flags: approval-mozilla-geckoview62?
Comment on attachment 9007026 [details]
Bug 1489250 - Don't send window changed event if a11y is off; r?eeejay

Approved for Fennec 63.0b5 and GV62.
Attachment #9007026 - Flags: approval-mozilla-geckoview62?
Attachment #9007026 - Flags: approval-mozilla-geckoview62+
Attachment #9007026 - Flags: approval-mozilla-beta?
Attachment #9007026 - Flags: approval-mozilla-beta+
(In reply to Ryan VanderMeulen [:RyanVM] from comment #9)
> Bug 1330257 never got uplifted to Fennec 62, so I'm having a hard time
> understanding why it's marked as affected.

OK. I wasn't sure if Fennec 62 was affected. (comment 4)
Tested with OnePlus 5T(Android 8.1.0) on 63.0b5 and we couldn't reproduce the crash following the information/steps provided. So verified as fixed.
Product: Firefox for Android → GeckoView
Keywords: crash, regression
Target Milestone: Firefox 64 → mozilla64
You need to log in before you can comment on or make changes to this bug.