Closed Bug 1489471 Opened Last year Closed Last year

WebRender: Startup fails

Categories

(Core :: Graphics: WebRender, defect, P1, major)

64 Branch
Desktop
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- unaffected
firefox64 --- fixed

People

(Reporter: Tobias.Marty, Assigned: nical)

References

Details

(Keywords: nightly-community, regression)

Attachments

(1 file)

-Updated Nightly to 64.0a1 (2018-09-06) (64-bit). 
-Restart from About Nightly dialog was okay. 
-Closed Nightly and tried to start it again. 

Nightly opens and renders an empty window with an empty new tab (no Acitivity Stream is showing). URL bar is empty. Hamburger menu can be opened but not interacted with or closed again. Close Nightly Windows button works, but nothing else. No CPU load, about 1.3 GB of RAM used. This state continues indefinitely.

After removing WebRender flag from prefs.js Nightly starts correctly again.
(Fix for regular Nightly: I just need to close the window and start Nightly again to see all restored tabs.)

It felt like an intermittent bug.

Testing manually:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9f53dc79984c400b17a8e3ddfa23df67ff7299ca&tochange=c4ee759903b0

1. Click on "Restart Nightly".
2. You see one empty tab. You can move invisible tabs out of the window.

> ef1988b6f9b8	Jeff Muizelaar — Bug 1488887. Update webrender to 46af5bf17978a97f0ab2a899a0d785d58c140a0a
mozregression --repo mozilla-inbound --launch ef1988b6f9b8 --pref gfx.webrender.all:true browser.startup.page:3 -a about:restartrequired -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471
bad

> 809efffd8f80	Petr Sumbera — Bug 1488217 build correctly snappy on big endian platforms r=glandium
mozregression --repo mozilla-inbound --launch 809efffd8f80 --pref gfx.webrender.all:true browser.startup.page:3 -a about:restartrequired -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471
good, good, good, good, good

---

Latest webrender update:
> c4ee759903b0 Jeff Muizelaar — Bug 1489127. Update webrender to commit 59656aa374706f25d7dc1b3b2c44970377efec22 
mozregression --repo mozilla-inbound --launch c4ee759903b0 --pref gfx.webrender.all:true browser.startup.page:3 -a about:restartrequired -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471
bad
Blocks: 1488887
No longer blocks: 1488217
> https://github.com/servo/webrender/pull/3009#issuecomment-418173616
mozregression --repo try --launch 4fc42b3e4e77699bff309491005f76ff1d3572fe --pref gfx.webrender.all:true browser.startup.page:3 -a about:restartrequired -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471
good, good, good

> https://github.com/servo/webrender/pull/3006#issuecomment-417898538
mozregression --repo try --launch ab178220f6d0d6cb5cff95937460624ad36426f0 --pref gfx.webrender.all:true browser.startup.page:3 -a about:restartrequired -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471
good, good, good

> https://github.com/servo/webrender/pull/2998#issuecomment-417709415
mozregression --repo try --launch e606386b9e899fcde16d8344fdc8c5ddaaf9e6e3 --pref gfx.webrender.all:true browser.startup.page:3 -a about:restartrequired -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471
bad, bad, bad

> https://github.com/servo/webrender/pull/3014#issuecomment-418440159
mozregression --repo try --launch b91f07ab2d18bc453b9bf8ced90ea8bd5492bffd --pref gfx.webrender.all:true browser.startup.page:3 -a about:restartrequired -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471
good, good, good

> https://github.com/servo/webrender/pull/3011#issuecomment-418554734
mozregression --repo try --launch 9a6cd6951e21d025d791e7aeef0ef7897c55649a --pref gfx.webrender.all:true browser.startup.page:3 -a about:restartrequired -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471 -a https://bugzilla.mozilla.org/show_bug.cgi?id=1489471
good, good, good

> https://github.com/servo/webrender/pull/2989
No try build found.


Likely regressed by servo/webrender#2998.
Flags: needinfo?(nical.bugzilla)
Priority: -- → P1
Assignee: nobody → nical.bugzilla
I see this issue on my Windows machine at home with my default profile, but in a new window (which I open with Strg+N because the UI is invisible). So I suspect it's something in the restored session that trips up WebRender... maybe it delays all transactions indefinitely or something.
(In reply to Markus Stange [:mstange] from comment #6)
> I see this issue on my Windows machine at home with my default profile, but
> in a new window (which I open with Strg+N because the UI is invisible).

but *not* in a new window. As in, the new window renders fine. The other window only shows the first painted frame, even after window resizes.
(In reply to Jeff Muizelaar [:jrmuizel] from comment #5)
> I'll make a build for https://github.com/servo/webrender/pull/2989

Doesn't servo/webrender#2989 depend anyway on servo/webrender#2998 (whose try build shows the bug)?
> This change is needed in order to get the low priority scene building in #2989 to work without requiring extra handshakes between the scene builder and the render backend threads.

Range of bug 1488887:
https://github.com/servo/webrender/compare/d89e290c57aab76c45d8016975240cf762354e39...46af5bf17978a97f0ab2a899a0d785d58c140a0a

Is ANGLE expecting something? I haven't seen this bug on Linux.
(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #9)
> (In reply to Jeff Muizelaar [:jrmuizel] from comment #5)
> > I'll make a build for https://github.com/servo/webrender/pull/2989
> 
> Doesn't servo/webrender#2989 depend anyway on servo/webrender#2998 (whose
> try build shows the bug)?

Yep. I assumed 2989 landed before 2998 but it didn't. Are there any builds that would be useful or we basically confident that it was 2998?
Flags: needinfo?(jan)
Help, what should I answer? :D Would you like to prepare a try build on top of current m-c with a patch to backout #2998 and #2989 to test if it fixes the problem?
Flags: needinfo?(jan)
Try build from bug 1489511 comment 1: bad
Try build from comment 12: 7x good, never bad
Severity: normal → major
See Also: → 1489189
Bug 1489189 seemed to be caused by same webrender change.
I also saw this problem on my win10 pc(P50).
Comment on attachment 9007696 [details]
Bug 1489471 - Ensure the renderer gets notified when a WebRender transaction requests a frame. r=mattwoodrow

Matt Woodrow (:mattwoodrow) has approved the revision.
Attachment #9007696 - Flags: review+
Pushed by nsilva@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0428cb7891ab
Ensure the renderer gets notified when a WebRender transaction requests a frame. r=mattwoodrow
Flags: needinfo?(nical.bugzilla)
I checked with a build from the CI of the autoland branch with this patch and the browser started with webrender properly.
https://hg.mozilla.org/mozilla-central/rev/0428cb7891ab
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.