Closed Bug 1489491 Opened 1 year ago Closed 1 year ago

Autofill ReverseSearch input with console input selected text if any

Categories

(DevTools :: Console, enhancement, P2)

enhancement

Tracking

(firefox66 fixed)

RESOLVED FIXED
Firefox 66
Tracking Status
firefox66 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

Details

Attachments

(1 file)

**Steps to reproduce**
1. Open the console
2. Enter `document` in the input
3. Select all the text in input (with Cmd/Ctrl+A)
4. Hit reverse search shortcut (Ctrl + R on OSX, tbd on Windows/Linux)

**Expected results**

The reverse search UI appears, with the input already filled with `document`

Nicolas, out of curiosity (as I keep running into this and because terminals to the same); is there a specific reason that this hasn't started yet? If not, could we plan it in for Bogaloo?

Flags: needinfo?(nchevobbe)

I don't think there's any specific reason aside from prioritization.
My guess is that it shouldn't take long, so maybe I can do it.

Flags: needinfo?(nchevobbe)
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
If the user selected some text in the console input
and opens the reverse search UI, we populate the
reverse search input with the selected text and do
a reverse search with this text.
A test is added to ensure this works as expected.
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/529a10531043
Populate reverse search with input text selection; r=bgrins.
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
You need to log in before you can comment on or make changes to this bug.