Extend the lifetime of some performance Telemetry probes so that they never expire

RESOLVED FIXED in Firefox 64

Status

()

RESOLVED FIXED
7 months ago
2 months ago

People

(Reporter: mconley, Assigned: mconley)

Tracking

unspecified
Firefox 64
Points:
---

Firefox Tracking Flags

(firefox64 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

7 months ago
In https://docs.google.com/spreadsheets/d/1WVpt6o6TxDum4VdP2cwvn3g4ySNRO5tNrzYAYsfOk5Q/edit#gid=1551356284&fvid=2072971067, a cross-org team of folks have identified the most important ("Tier 1") Telemetry probes in our tree that we'll want to measure indefinitely.

This bug tracks the effort to adjust the lifetime of these probes (with the sole exception of FX_TAB_CLOSE_TIME_ANIM_MS, which is already being patched separately in Bug 1488952).
(Assignee)

Comment 2

7 months ago
In this patch, I applied the following changes to the probes in comment 0:

1) I made their expiry "never"
2) I added this bug_number to their bug_number list
3) I updated the alert_emails to match the doc
4) For some probes that I'm certain have no business being collected in the content process, I removed "content" from "record_in_process"
4) I set their releaseChannelCollection to "opt-out".


(4) is the only thing I'm not 100% sure I needed to do, so I'd like to double-check with vchin - Vicky, did we want these probes to be opt-out on the release channel as well?
Flags: needinfo?(vchin)
Yes 4) looks good. Thanks mconley.
Flags: needinfo?(vchin)
(Assignee)

Comment 4

7 months ago
Okay, thanks.

I'm waiting to request data-review, as these is a large number of probes we're bumping here, and chutten thinks there's a shorter way. He's reached out to rweiss to see if we can use the new Data Collection Review Short Form for it. Waiting to hear back.
Comment on attachment 9007266 [details]
Bug 1489524 - Extend the life of probes identified as Tier 1 for Performance and make opt-out on release. data-review=chutten

Panos Astithas (he/him) [:past] (please ni?) has approved the revision.
Attachment #9007266 - Flags: review+
(Assignee)

Updated

7 months ago
Assignee: nobody → mconley
Status: NEW → ASSIGNED
(Assignee)

Comment 7

7 months ago
Comment on attachment 9008148 [details]
epic-data-review-form

Hey chutten, I never heard back about the shorter form, so I just filled out this one. Sorry about the length! Let me know if you need anything else.
Attachment #9008148 - Flags: review?(chutten)

Comment 8

7 months ago
Comment on attachment 9008148 [details]
epic-data-review-form

Preliminary note:
It may be worth having automated test coverage on the pieces of code that collect these metrics ensuring that data collection works and isn't accidentally broken in the future. (For instance, painting content should increase the count of CONTENT_PAINT_TIME by exactly 1 with a non-0 sample). This isn't a requirement of review, it's just prudent.

DATA COLLECTION REVIEW RESPONSE:

    Is there or will there be documentation that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes: standard Telemetry mechanisms (like the Probe Dictionary) apply.

    Is there a control mechanism that allows the user to turn the data collection on and off?

Yes: standard Telemetry mechanisms (the pref in about:preferences#privacy) apply.

    If the request is for permanent data collection, is there someone who will monitor the data over time?

Yes. Each measure has at least one someone who will monitor it.

    Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Though all are listed as Cat2 in the table, some are Cat1. Rounding up, that's Category 2.

    Is the data collection request for default-on or default-off?

Default on.

    Does the instrumentation include the addition of any new identifiers (whether anonymous or otherwise; e.g., username, random IDs, etc. See the appendix for more details)?

No.
    Is the data collection covered by the existing Firefox privacy notice? 

Yes.

    Does there need to be a check-in in the future to determine whether to renew the data?

No. Permanent collections.

---
Result: datareview+
Attachment #9008148 - Flags: review?(chutten) → review+
(Assignee)

Comment 9

7 months ago
Thanks!
Attachment #9007266 - Attachment description: Bug 1489524 - Extend the life of probes identified as Tier 1 for Performance and make opt-out on release. → Bug 1489524 - Extend the life of probes identified as Tier 1 for Performance and make opt-out on release. data-review=chutten

Comment 10

7 months ago
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/45e629e8498c
Extend the life of probes identified as Tier 1 for Performance and make opt-out on release. data-review=chutten r=past

Comment 11

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/45e629e8498c
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
status-firefox64: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64

Updated

5 months ago
Duplicate of this bug: 1360644
See Also: → bug 1519409
You need to log in before you can comment on or make changes to this bug.