Closed Bug 1489612 Opened 1 year ago Closed 1 year ago

XUL tooltips don't work on in browser.xhtml

Categories

(Core :: XUL, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: bdahl, Assigned: bdahl)

References

Details

Attachments

(1 file)

From bug 1486716

(Brian Grinstead [:bgrins]
> Thanks for filing. I've noticed another problem with tooltips with XUL
> elements in HTML documents when fixing tests for browser.xhtml:
> 
> 1) mk_add_options 'export MOZ_BROWSER_XHTML=1'
> 2) `./mach run` then hover over a tab title, or back button, or whatever
> 
> A small tooltip bubble pops up, but no text is inside of it. Do you think
> that's the same root cause as this bug or something different?
A XUL element within an HTML document should still follow the normal code
path for finding the tooltip element instead of always using the default
tooltip.

MozReview-Commit-ID: IBAmk1m4Zp0
Comment on attachment 9007327 [details]
Bug 1489612 - Fix XUL tooltips in HTML documents. r=smaug

Olli Pettay [:smaug] has approved the revision.
Attachment #9007327 - Flags: review+
Pushed by bdahl@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b4028ac4b1a5
Fix XUL tooltips in HTML documents. r=smaug
https://hg.mozilla.org/mozilla-central/rev/b4028ac4b1a5
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Component: General → XUL
Product: Firefox → Core
Target Milestone: Firefox 64 → mozilla64
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.