Intermittent toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | Expected cookie value - Expected: cookie=monster, Actual:

RESOLVED FIXED in Firefox 64

Status

defect
P5
normal
RESOLVED FIXED
10 months ago
5 months ago

People

(Reporter: intermittent-bug-filer, Assigned: apavel)

Tracking

({intermittent-failure})

unspecified
mozilla64
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox64 fixed)

Details

(Whiteboard: [stockwell disabled])

Attachments

(1 attachment)

Reporter

Description

10 months ago
treeherder
Filed by: ccoroiu [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=198231887&repo=mozilla-central

https://queue.taskcluster.net/v1/task/IQamtekDQc6tlTbkeqkTfA/runs/0/artifacts/public/logs/live_backing.log

task 2018-09-08T14:09:37.175Z] 14:09:37     INFO - TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | test result correct 
[task 2018-09-08T14:09:37.176Z] 14:09:37     INFO - AddTask.js | Leaving test test_webext_contentscript_iframe_subframe_privileges
[task 2018-09-08T14:09:37.177Z] 14:09:37     INFO - AddTask.js | Entering test test_webext_background_remote_subframe_privileges
[task 2018-09-08T14:09:37.179Z] 14:09:37     INFO - Extension loaded
[task 2018-09-08T14:09:37.180Z] 14:09:37     INFO - TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | postmessage origin ok - Expected: http://mochi.test:8888, Actual: http://mochi.test:8888 
[task 2018-09-08T14:09:37.181Z] 14:09:37     INFO - TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | remote frame cannot access webextension APIs 
[task 2018-09-08T14:09:37.183Z] 14:09:37     INFO - Buffered messages finished
[task 2018-09-08T14:09:37.184Z] 14:09:37     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | Expected cookie value - Expected: cookie=monster, Actual:  
[task 2018-09-08T14:09:37.185Z] 14:09:37     INFO -     @moz-extension://be17e47b-669b-43f0-8276-5acaa4730024/background-subframe.js:5:7
[task 2018-09-08T14:09:37.186Z] 14:09:37     INFO -     EventListener.handleEvent*backgroundSubframeScript@moz-extension://be17e47b-669b-43f0-8276-5acaa4730024/background-subframe.js:2:5
[task 2018-09-08T14:09:37.188Z] 14:09:37     INFO -     @moz-extension://be17e47b-669b-43f0-8276-5acaa4730024/background-subframe.js:1:11
[task 2018-09-08T14:09:37.189Z] 14:09:37     INFO -     
[task 2018-09-08T14:09:37.190Z] 14:09:37     INFO - TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | webext-background-subframe-privileges 
[task 2018-09-08T14:09:37.192Z] 14:09:37     INFO - TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | test result correct 
[task 2018-09-08T14:09:37.193Z] 14:09:37     INFO - AddTask.js | Leaving test test_webext_background_remote_subframe_privileges
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Assignee

Comment 3

10 months ago
This seems to be from here: https://hg.mozilla.org/integration/mozilla-inbound/rev/318b1252e9ba83cf071f2ae1b8729158be346760

Kris, please take a look.
Flags: needinfo?(kmaglione+bmo)
I just fixed the ridiculous assertion message. The failure isn't new.
Flags: needinfo?(kmaglione+bmo)

Updated

10 months ago
Duplicate of this bug: 1489705
Assignee

Comment 6

10 months ago
okay, but since you changed https://hg.mozilla.org/integration/mozilla-inbound/rev/318b1252e9ba83cf071f2ae1b8729158be346760#l1.13 and the failure mentions  "Expected cookie value - Expected: cookie=monster" is there a possibility it's from there? did you modify it somewhere else? this is a rather frequent failure.
Flags: needinfo?(kmaglione+bmo)
This has nothing to do with my change. I made that change because I saw the existing intermittent failure and was annoyed by the absurd assertion message.
Flags: needinfo?(kmaglione+bmo)
Comment hidden (Intermittent Failures Robot)
Assignee

Comment 9

9 months ago
There are 71 total failures in the last 7 days, all on android-em-4-3-armv7-api16

Recent failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=200048817&repo=autoland&lineNumber=1744

[task 2018-09-18T23:11:48.275Z] 23:11:48     INFO -  31 INFO TEST-START | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html
[task 2018-09-18T23:13:02.093Z] 23:13:02     INFO -  Buffered messages logged at 23:11:44
[task 2018-09-18T23:13:02.094Z] 23:13:02     INFO -  32 INFO AddTask.js | Entering test test_webext_tab_subframe_privileges
[task 2018-09-18T23:13:02.095Z] 23:13:02     INFO -  33 INFO Extension loaded
[task 2018-09-18T23:13:02.096Z] 23:13:02     INFO -  Buffered messages logged at 23:12:11
[task 2018-09-18T23:13:02.097Z] 23:13:02     INFO -  34 INFO TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | Subframe of a privileged page has access to privileged APIs
[task 2018-09-18T23:13:02.098Z] 23:13:02     INFO -  Buffered messages logged at 23:12:20
[task 2018-09-18T23:13:02.099Z] 23:13:02     INFO -  35 INFO TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | webext-tab-subframe-privileges
[task 2018-09-18T23:13:02.099Z] 23:13:02     INFO -  36 INFO TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | test result correct
[task 2018-09-18T23:13:02.099Z] 23:13:02     INFO -  Buffered messages logged at 23:12:21
[task 2018-09-18T23:13:02.099Z] 23:13:02     INFO -  37 INFO AddTask.js | Leaving test test_webext_tab_subframe_privileges
[task 2018-09-18T23:13:02.100Z] 23:13:02     INFO -  38 INFO AddTask.js | Entering test test_webext_background_subframe_privileges
[task 2018-09-18T23:13:02.100Z] 23:13:02     INFO -  39 INFO Extension loaded
[task 2018-09-18T23:13:02.100Z] 23:13:02     INFO -  Buffered messages logged at 23:12:27
[task 2018-09-18T23:13:02.100Z] 23:13:02     INFO -  40 INFO TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | Subframe of a background page has access to privileged APIs
[task 2018-09-18T23:13:02.100Z] 23:13:02     INFO -  41 INFO TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | webext-background-subframe-privileges
[task 2018-09-18T23:13:02.101Z] 23:13:02     INFO -  42 INFO TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | test result correct
[task 2018-09-18T23:13:02.102Z] 23:13:02     INFO -  43 INFO AddTask.js | Leaving test test_webext_background_subframe_privileges
[task 2018-09-18T23:13:02.102Z] 23:13:02     INFO -  44 INFO AddTask.js | Entering test test_webext_contentscript_iframe_subframe_privileges
[task 2018-09-18T23:13:02.103Z] 23:13:02     INFO -  Buffered messages logged at 23:12:28
[task 2018-09-18T23:13:02.103Z] 23:13:02     INFO -  45 INFO Extension loaded
[task 2018-09-18T23:13:02.104Z] 23:13:02     INFO -  Buffered messages logged at 23:12:44
[task 2018-09-18T23:13:02.105Z] 23:13:02     INFO -  46 INFO TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | Subframe of a content script privileged iframes has no access to privileged APIs
[task 2018-09-18T23:13:02.106Z] 23:13:02     INFO -  47 INFO TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | Subframe of a content script privileged iframes has access to content script APIs
[task 2018-09-18T23:13:02.107Z] 23:13:02     INFO -  48 INFO TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | webext-contentscript-subframe-privileges
[task 2018-09-18T23:13:02.108Z] 23:13:02     INFO -  49 INFO TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | test result correct
[task 2018-09-18T23:13:02.110Z] 23:13:02     INFO -  Buffered messages logged at 23:12:46
[task 2018-09-18T23:13:02.110Z] 23:13:02     INFO -  50 INFO AddTask.js | Leaving test test_webext_contentscript_iframe_subframe_privileges
[task 2018-09-18T23:13:02.111Z] 23:13:02     INFO -  51 INFO AddTask.js | Entering test test_webext_background_remote_subframe_privileges
[task 2018-09-18T23:13:02.111Z] 23:13:02     INFO -  52 INFO Extension loaded
[task 2018-09-18T23:13:02.112Z] 23:13:02     INFO -  Buffered messages logged at 23:12:58
[task 2018-09-18T23:13:02.112Z] 23:13:02     INFO -  53 INFO TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | postmessage origin ok - Expected: http://mochi.test:8888, Actual: http://mochi.test:8888
[task 2018-09-18T23:13:02.113Z] 23:13:02     INFO -  54 INFO TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | remote frame cannot access webextension APIs
[task 2018-09-18T23:13:02.113Z] 23:13:02     INFO -  Buffered messages finished
[task 2018-09-18T23:13:02.114Z] 23:13:02     INFO -  55 INFO TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | Expected cookie value - Expected: cookie=monster, Actual:
[task 2018-09-18T23:13:02.114Z] 23:13:02     INFO -      @moz-extension://b4d7cc91-a88c-4e40-a91b-80eb0fc4ff23/background-subframe.js:5:7
[task 2018-09-18T23:13:02.115Z] 23:13:02     INFO -  56 INFO TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | webext-background-subframe-privileges
[task 2018-09-18T23:13:02.116Z] 23:13:02     INFO -  57 INFO TEST-PASS | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | test result correct
[task 2018-09-18T23:13:02.116Z] 23:13:02     INFO -  58 INFO AddTask.js | Leaving test test_webext_background_remote_subframe_privileges
[task 2018-09-18T23:13:02.117Z] 23:13:02     INFO -  59 INFO TEST-OK | toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | took 78729ms
Whiteboard: [stockwell needswork:owner]
Comment hidden (Intermittent Failures Robot)
The only non-Android failures here have been with test-verify which lets the test run very often and is likely pre-existing.

The frequent Android failures start shortly before the renaming of the string, when the test chunks got increased in bug 1489645.
Blocks: 1489645
Flags: needinfo?(gbrown)
This test previously ran in android/debug mochitest-48. The only difference I see is that mochitest-48 was running toolkit/components/alerts/test before toolkit/components/extensions/test/mochitest tests; with the new chunks, mochitest-60 runs toolkit/components/extensions/test/mochitest as the first manifest in the task. The TV failures may also indicate that this test relies on state from earlier tests. 

The additional test chunks are needed and we cannot guarantee test order across manifests. Unless someone can investigate further, I suggest disabling this test, at least, skip-if = os == 'android' || verify.
Flags: needinfo?(gbrown)
Comment hidden (Intermittent Failures Robot)
Assignee

Comment 14

9 months ago
Geoff please take a look and let me know what needs to be changed if any. 
Thank you.
Assignee: nobody → apavel
Attachment #9010826 - Flags: review?(gbrown)
Comment hidden (Intermittent Failures Robot)
Comment on attachment 9010826 [details] [diff] [review]
disabled test on android

Review of attachment 9010826 [details] [diff] [review]:
-----------------------------------------------------------------

That looks fine - thanks!
Attachment #9010826 - Flags: review?(gbrown) → review+
Comment hidden (Intermittent Failures Robot)

Comment 18

9 months ago
Pushed by rgurzau@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e7fcb90e8848
disable test_ext_subframes_privileges.html on android r=gbrown

Comment 19

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e7fcb90e8848
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Comment hidden (Intermittent Failures Robot)
No new failures since 22th of September.

Updated

9 months ago
Flags: qe-verify-

Updated

5 months ago
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
You need to log in before you can comment on or make changes to this bug.