New tab doesn't focus the address bar with multi-account containers

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
8 months ago
8 months ago

People

(Reporter: firefox, Unassigned)

Tracking

({regression})

63 Branch
Desktop
Linux

Firefox Tracking Flags

(firefox62 unaffected, firefox63 fixed, firefox64 fixed)

Details

(Reporter)

Description

8 months ago
Working on Stable:
1. Install 62.0-2 from snap (sudo snap install firefox) on Ubuntu.
2. Install https://addons.mozilla.org/en-US/firefox/addon/multi-account-containers/
3. Open a new tab, see how you can just type as it has the cursor.
Open a new container tab, see how you can just type as it has the cursor.

Regressed on Beta:
1. Install 63.0b4-1 from snap (sudo snap refresh firefox --beta) on Ubuntu.
2. (skip if upgrading) Install https://addons.mozilla.org/en-US/firefox/addon/multi-account-containers/
3. Open a new tab, see how you can just type as it has the cursor. *STILL WORKS*
Open a new container tab, see how you can no longer just type as it doesn't have the cursor. *REGRESSION*

I also use temporary containers with all new tabs defaulting to temporary (https://addons.mozilla.org/en-US/firefox/addon/temporary-containers/) and others who do similar will have a bigger impact from this bug.

I also tested it on Firefox nightly 64.0a1 (2018-09-09) (using tarball as it's not snapped) and it is affected by this regression as well.

Would be useful to confirm if this is Linux specific or not (Windows or Mac users please test - thanks!). I'm going to try to narrow down when the issue landed.
(In reply to Bryan Quigley from comment #1)
> Looks like it was in the first nightly build of 2018-08-10.

Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cea8cf3f6abefaccb80a640b47aad8bcdb3115ae&tochange=d999fb858fb2c007c5be4af72bce419c63c69b8e

I can't reproduce this in Nightly on Ubuntu.
(Reporter)

Comment 3

8 months ago
@Dão Thanks for trying to reproduce -  what desktop environment are you using?  What Ubuntu version? (I am on stock Ubuntu - GNOME actually on 18.04 LTS)

Another reproduction procedure I just tried in an Ubuntu VM with Nightly Firefox:
1. Install https://addons.mozilla.org/en-US/firefox/addon/temporary-containers/
2. Click new tab button using mouse, note how you can type in address bar with no further clicks
3. Click new temporary tab using mouse, note how if you type it goes nowhere

There are quite a few related to tabs and focus on that list. Thanks for it!
Keywords: regression
Summary: [regression] Firefox 63 beta - Focusing on new tabs breaks for multi-account containers → Focusing on new tabs breaks for multi-account containers
Flags: needinfo?(dao+bmo)
(In reply to Bryan Quigley from comment #3)
> @Dão Thanks for trying to reproduce -  what desktop environment are you
> using?  What Ubuntu version? (I am on stock Ubuntu - GNOME actually on 18.04
> LTS)

Same.

> Another reproduction procedure I just tried in an Ubuntu VM with Nightly
> Firefox:
> 1. Install
> https://addons.mozilla.org/en-US/firefox/addon/temporary-containers/
> 2. Click new tab button using mouse, note how you can type in address bar
> with no further clicks
> 3. Click new temporary tab using mouse, note how if you type it goes nowhere
> 
> There are quite a few related to tabs and focus on that list. Thanks for it!

Can you reproduce this without add-ons, just by enabling containers in Nightly?
Flags: needinfo?(dao+bmo) → needinfo?(firefox)
(Reporter)

Comment 5

8 months ago
Nope, I had not idea you could container tabs without the official Mozilla add-on.  

It does not impact the if you hold down the new tab button and choose your container that way.  (I also had not idea you could do that).

Do all the add-ons need to be updated due to a Firefox change?
Flags: needinfo?(firefox)
Component: Tabbed Browser → Frontend
Product: Firefox → WebExtensions
Summary: Focusing on new tabs breaks for multi-account containers → New tab doesn't focus the address bar with multi-account containers
(Reporter)

Comment 6

8 months ago
Looks like this got fixed in 63.0b8-1. Haven't figured out by what though..
Can we verify this fixed, please?
Flags: needinfo?(kraj)
Vlad, please verify that this is fixed asap.
Flags: needinfo?(kraj) → needinfo?(vlad.jiman)

Comment 9

8 months ago
Hi, using the extension in question and the Temporary Containers addon, I've managed to reproduce the issue using the following builds: Nightly 63.0a1, 63.0b7, after 0b7 it seems to be fixed as I could no longer reproduce it on 63.0b8 and 63.0b9. Tests were run using Ubuntu 18.04 LTS.
Flags: needinfo?(vlad.jiman)
I assume this is fixed in current Nightly 64 too?
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WORKSFORME

Comment 11

8 months ago
Yes, I can confirm that the current Nightly 64 is fixed as well.
You need to log in before you can comment on or make changes to this bug.