Status

()

defect
RESOLVED DUPLICATE of bug 1283299
8 months ago
7 months ago

People

(Reporter: soloturn, Unassigned)

Tracking

62 Branch
Points:
---

Firefox Tracking Flags

(firefox62 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180905135451

Steps to reproduce:

firefix on gnome linux takes 4 lines on top of the screen on a gnome desktop. first, gnome (with activities, and a firefox menu which has only "quit"). second, a title bar, only showing the title, and a button to close the window. third a tab bar, showing the title again and again a close button. fourth the buttons, the url and again a menu, this time more useful, with a quit in it. also the text is long, it always says "mozilla firefox" instead of "firefox" or nothing in the title. when pressing the windows key to get a window overview as well.




Expected results:

chromium is better, three lines on top taken. one for a combined title / tab. one for the url, and buttons.

epiphany uses only two lines. the top menu in the gnome bar is actually useful.  when pressing the windows key to get the overview of windows, only the title and no program name "web" is displayed.
(Reporter)

Comment 1

8 months ago
(Reporter)

Comment 2

8 months ago

Comment 3

8 months ago
Feel free to make Firefox hide the tab when only one tab is open?

Firefox is not a GNOME application so it might have a different approach when it comes to using title bars.

I'm not sure what's requested here and no actual and underlying problem to solve is described in this ticket. "better" is subjective.
Flags: needinfo?(soloturn)
Component: Untriaged → Tabbed Browser
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: gtktitlebar
Flags: needinfo?(soloturn)
Note: Just disable the titlebar at Customize menu.
You need to log in before you can comment on or make changes to this bug.