Closed Bug 1490633 Opened 1 year ago Closed 1 year ago

Fullshape colon and semicolon are 90° rightward rotated when writing-mode = tb-rl

Categories

(Core :: Layout: Text and Fonts, defect)

61 Branch
defect
Not set

Tracking

()

RESOLVED INVALID
Tracking Status
firefox62 --- affected
firefox63 --- affected
firefox64 --- affected

People

(Reporter: danny0838, Unassigned)

Details

Attachments

(1 file)

Attached file font.html
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180807170231

Steps to reproduce:

1. Open the font.html file in the attachment.
2. Check how fullshape colon (冒號; U+FF1A) and semicolon (分號; U+FF1B) are displayed.




Actual results:

The fullshape colon and semicolon are 90° rightward rotated if writing-mode = tb-rl and text-orientation != upright.


Expected results:

The fullshape colon and semicolon should not be 90° rightward rotated if writing-mode = tb-rl and text-orientation != upright, as in Chrome or IE.

* Fullshape colon (冒號; U+FF1A) and semicolon (分號; U+FF1B) are used commonly in CJKV texts, and they, as any Chinese characters and punctuations, should not be 90° rightward rotated when writing-mode = tb-rl and text-orientation != upright.
Hi Danny,

  I've tested and I can reproduce your issue on the latest builds from Nightly 64(20180916220033), Beta 63(20180913141435) and Release 62(20180830143136) channels.
Environments covered: MacOs 10.12, Ubuntu 16.04, Win10 x64, Win7 x64

Thanks for reporting!
Component: Untriaged → Layout: Text and Fonts
Product: Firefox → Core
Status: UNCONFIRMED → NEW
Ever confirmed: true
This isn't a Firefox bug, it's a font issue. The rendering of U+FF1A and U+FF1B in vertical writing mode is dependent on what glyphs the font provides for the 'vert' feature; as documented at http://www.unicode.org/reports/tr50/#table_2 there may be various design options, including both "original" and "rotated" forms. So it's up to the font designer.

And sure enough, I see different results depending on the font chosen.

In the case of the DFKai-SB font, as specified in the testcase here, the font doesn't provide 'vert' alternates for these characters at all. (AFAICT this is quite an old font, shipped with earlier versions of Windows.) It has a GSUB table, and supports the 'vert' feature, but these characters are missing from it.

So in that case, we apply the fallback rendering specified by Unicode, which for these characters means rotating the glyph by 90°, because they have the Vertical_Orientation property Tr. (See https://www.unicode.org/Public/UCD/latest/ucd/VerticalOrientation.txt.)

If some other browsers render these characters differently (using the DFKai-SB font), I can only assume they don't fully implement the Tr (Transformed typographically, with fallback to Rotated) value of the Unicode Vertical_Orientation property, and this should be reported as a bug against those browsers.
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.