Crash in mozilla::dom::Promise::MaybeSomething<T>

RESOLVED DUPLICATE of bug 1490698

Status

()

defect
P2
critical
RESOLVED DUPLICATE of bug 1490698
9 months ago
8 months ago

People

(Reporter: calixte, Unassigned)

Tracking

(Blocks 1 bug, {crash, regression})

64 Branch
Unspecified
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox62 unaffected, firefox63 unaffected, firefox64 fixed)

Details

(crash signature)

Reporter

Description

9 months ago
This bug was filed from the Socorro interface and is
report bp-2949b71b-df82-4a46-bea5-df4bc0180912.
=============================================================

Top 10 frames of crashing thread:

0 xul.dll void mozilla::dom::Promise::MaybeSomething<nsresult&> dom/promise/Promise.h:227
1 xul.dll void mozilla::dom::PaymentResponse::RejectRetry dom/payments/PaymentResponse.cpp:263
2 xul.dll void mozilla::dom::PaymentRequest::RejectShowPayment dom/payments/PaymentRequest.cpp:752
3 xul.dll mozilla::dom::PaymentRequestManager::RespondPayment dom/payments/PaymentRequestManager.cpp:630
4 xul.dll mozilla::dom::PaymentRequestChild::RecvRespondPayment dom/payments/ipc/PaymentRequestChild.cpp:44
5 xul.dll mozilla::dom::PPaymentRequestChild::OnMessageReceived ipc/ipdl/PPaymentRequestChild.cpp:134
6 xul.dll void mozilla::ipc::MessageChannel::DispatchMessageW ipc/glue/MessageChannel.cpp:2175
7 xul.dll mozilla::ipc::MessageChannel::MessageTask::Run ipc/glue/MessageChannel.cpp:2045
8 xul.dll mozilla::SchedulerGroup::Runnable::Run xpcom/threads/SchedulerGroup.cpp:337
9 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1161

=============================================================

There are 3 crashes (from 2 installations) in nightly 64 starting with buildid 20180911224301. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1435161.

[1] https://hg.mozilla.org/mozilla-central/rev?node=e65bec7e01c8
Flags: needinfo?(echuang)
Yes, it looks like a dupe of bug 1490698. I have already attached the patch for it.
I will keep monitoring this bug to check if the patch of bug 1490698 resolves the problem or not.
Flags: needinfo?(echuang)
Priority: -- → P2
Although I think the crash signature is the same with bug 1490698.
Now bug 1490698 is checked in, let see if it influences this bug, too.
Duping to Bug 1490698. The crashes seemed to have ceased following the 9-14 fix for that bug.
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1490698
You need to log in before you can comment on or make changes to this bug.