3D Emoji Town flickers with WebRender

RESOLVED FIXED in Firefox 64

Status

()

defect
P1
normal
RESOLVED FIXED
11 months ago
11 months ago

People

(Reporter: TD-Linux, Assigned: kvark)

Tracking

(Blocks 1 bug, {regression})

Trunk
mozilla64
Unspecified
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox62 disabled, firefox63 disabled, firefox64 fixed)

Details

()

Attachments

(1 attachment)

When rotating the town with the slider, the roads appear and disappear based on angle.
Searched the moment when the roads began to flicker.

mozregression --good 2018-04-05 --bad 2018-09-05 --pref gfx.webrender.all:true -a https://codepen.io/GeorgePark/full/MqVoYP/
> 12:02.70 INFO: Last good revision: fc4f2d0a1dfb663404260c36c1b5f85fc1b14f96
> 12:02.70 INFO: First bad revision: 84f298282f592fceb8f5f5bb9f3bbfafdf3b7d60
> 12:02.70 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=fc4f2d0a1dfb663404260c36c1b5f85fc1b14f96&tochange=84f298282f592fceb8f5f5bb9f3bbfafdf3b7d60

> 84f298282f59	Kartikaya Gupta — Bug 1459935 - Update for API change in WR PR 2747. r=jrmuizel
> 3ad8053cee91	Kartikaya Gupta — Bug 1459935 - Update Cargo lockfiles and re-vendor rust dependencies. r=jrmuizel
> 972eab977ff3	Kartikaya Gupta — Bug 1459935 - Update webrender to commit 4811a6e7c06f9dd1b4056e5f5e66983842983ba0. r=jrmuizel

Regression range: https://github.com/servo/webrender/compare/9a3bc6b965554c04c0bba326cdee45240c3b4ba7...4811a6e7c06f9dd1b4056e5f5e66983842983ba0

(Sorry, OBS was dying.)
last good (left): mozregression --repo autoland --launch fc4f2d0a1dfb663404260c36c1b5f85fc1b14f96 --pref gfx.webrender.all:true -a https://codepen.io/GeorgePark/full/MqVoYP/
first bad (right): mozregression --repo autoland --launch 84f298282f592fceb8f5f5bb9f3bbfafdf3b7d60 --pref gfx.webrender.all:true -a https://codepen.io/GeorgePark/full/MqVoYP/
Priority: -- → P1
Seems likely 3d-transform-related. Glenn?
Flags: needinfo?(gwatson)
Yes, I think so. I ran Gecko with current WR, and it looks better than when the video was captured, but still not correct.

It looks like the backface culling fixes that landed recently probably improved things.

My guess is that the remaining issues (roads flickering on and off) might be related to z-sorting accuracy - this is something that Dzmitry and I have been discussing offline. It might be something else, but that's probably the first thing to check?
Flags: needinfo?(gwatson) → needinfo?(kvark)
What I see is the roads flickering, which is certainly related to plane splitting precision/thresholds.
Assignee: nobody → kvark
Flags: needinfo?(kvark)
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.