Closed Bug 1491624 Opened 3 years ago Closed 3 years ago

Ctrl+Z Undo in a textarea sometimes skips over the desired editing state

Categories

(Core :: DOM: Editor, defect, P3)

63 Branch
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: from_bugzilla2, Unassigned)

Details

(Keywords: regressionwindow-wanted)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180906162647

Steps to reproduce:

0. Open up a fresh Firefox Nightly profile
1. Open up a question on the English Language & Usage Stack Exchange.
2. Type "Sorry if this actually gets posted. I'm trying to diagnoz" into the answer field 
3. Backspace the "z" and complete the sentence with "se a Firefox bug."
4. Press Ctrl+Z


Actual results:

The sentence will be rewound to "diagnoz", which is not how I'm used to it working and seems to not universally be the case.

(The Undo context menu entry is overeager to disable itself at times when Ctrl+Z still works, but it doesn't seem to suffer from this problem when used against the same Undo history.)


Expected results:

Normally, it takes two presses of Ctrl+Z to get the typo back, with the first producing the state just after the backspacing was done ("diagno").
is it a regression?
Component: Untriaged → Editor
Product: Firefox → Core
I don't remember the problem occurring before, but I'll need a day or two to find time to install a copy of Firefox 52 ESR and verify that.
Keywords: stalled
Priority: -- → P3
Sorry about the delay. My TODOs got a bit backed up.

I just jumped this to the head of the line and ran the test now. It's not a regression since 52 ESR.

However, I did discover a more likely candidate... It doesn't manifest on all sites. (eg. It doesn't happen on Bugzilla but it does happen on StackExchange.)

It looks like this is actually a StackExchange bug, given that clicking the Undo/Redo buttons in the toolbar above the textarea behaves as expected.

Sorry for taking up your time with it.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.