Closed Bug 149168 Opened 19 years ago Closed 19 years ago

self.status javascript affects status bar on every tabbed page

Categories

(SeaMonkey :: Tabbed Browser, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 104532

People

(Reporter: teemu, Assigned: jag+mozilla)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    2002051009

I have several tabs open, each on a different site.
If I run this example javascript on any of the tabbed pages and then change to
tabs on different sites, the status bar continues to be affected by the javascript.

function test()
{
   window.setTimeout( "test()", 1000 );
   self.status = "test";
}


Reproducible: Always
Steps to Reproduce:
1. Create a page with the javascript
2. Open the page
3. Open a couple other sites to different tabs
4. Switch between the tabs and watch the status bar


Actual Results:  The status bar is affected by the javascript run in other tab.

Expected Results:  The status bar should not be affected by the javascript run
in another tab.

*** This bug has been marked as a duplicate of 104532 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.