Closed Bug 1492114 Opened Last year Closed Last year

Third-party cookies description is unnecessarily wrapped

Categories

(Firefox :: Preferences, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 64
Tracking Status
firefox63 --- verified
firefox64 --- verified

People

(Reporter: flod, Assigned: ehsan)

References

Details

Attachments

(3 files)

All other descriptions used the available space, while blockCookiesCBDeck has a max-width of 444px

https://searchfox.org/mozilla-central/rev/6c82481caa506a240a626bb44a2b8cbe0eedb3a0/browser/themes/shared/incontentprefs/privacy.css#135
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Priority: -- → P1
Comment on attachment 9009974 [details]
Bug 1492114 - Ensure that the Third-Party Cookies description doesn't wrap unnecessarily

Johann Hofmann [:johannh] has approved the revision.
Attachment #9009974 - Flags: review+
Attachment #9009974 - Attachment description: Bug 1492114 - Ensure that the Third-Party Cookies description doesn't wrap unnecessarily; r=johannh → Bug 1492114 - Ensure that the Third-Party Cookies description doesn't wrap unnecessarily
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fd174216895b
Ensure that the Third-Party Cookies description doesn't wrap unnecessarily r=johannh
flod, I'd appreciate if you could verify the fix when this merges into Nightly.  Thanks!
Flags: needinfo?(francesco.lodolo)
https://hg.mozilla.org/mozilla-central/rev/fd174216895b
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
I'm using a build (64.0a1 (2018-09-21) (64 bit)) based on
https://hg.mozilla.org/mozilla-central/rev/eddbfdc38cbc

Which includes your landing (I see the CSS too in DevTools), but the issue is still there.
Flags: needinfo?(francesco.lodolo) → needinfo?(ehsan)
Of course, sorry!  I got the selectors wrong.  :-(
Status: RESOLVED → REOPENED
Flags: needinfo?(ehsan)
Resolution: FIXED → ---
The selector should apply to deck elements that do have a selectedIndex
attribute but it's not 0.
Note that you can test this with pseudolocale, it's long enough to wrap
https://firefox-source-docs.mozilla.org/intl/l10n/l10n/fluent_tutorial.html#pseudolocalization
Comment on attachment 9011179 [details]
Bug 1492114 - Really ensure that the Third-Party Cookies description doesn't wrap unnecessarily

Johann Hofmann [:johannh] has approved the revision.
Attachment #9011179 - Flags: review+
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1c366e594aeb
Really ensure that the Third-Party Cookies description doesn't wrap unnecessarily r=johannh
(In reply to Francesco Lodolo [:flod] from comment #9)
> Note that you can test this with pseudolocale, it's long enough to wrap
> https://firefox-source-docs.mozilla.org/intl/l10n/l10n/fluent_tutorial.
> html#pseudolocalization

Very nice, I wasn't aware of this!  I tested this patch by editing the string in devtools.  :-)
Comment on attachment 9009974 [details]
Bug 1492114 - Ensure that the Third-Party Cookies description doesn't wrap unnecessarily

Approval Request Comment
[Feature/Bug causing the regression]: New feature
[User impact if declined]: comment 0
[Is this code covered by automated tests?]: Tested locally
[Has the fix been verified in Nightly?]: Not yet
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: Both patches need to be uplifted
[Is the change risky?]: No
[Why is the change risky/not risky?]: Simple theme change
[String changes made/needed]: none
Attachment #9009974 - Flags: approval-mozilla-beta?
Comment on attachment 9009974 [details]
Bug 1492114 - Ensure that the Third-Party Cookies description doesn't wrap unnecessarily

Simple CSS fix for l10n builds verified on nightly by flod, uplift approved for 63 beta 9 thanks.
Attachment #9009974 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
https://hg.mozilla.org/mozilla-central/rev/1c366e594aeb
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Resolution: --- → FIXED
Also verified on 64.0a1 (2018-09-24) (64 bit)
Status: RESOLVED → VERIFIED
Managed to reproduce the issue on 63.0b8.
Verified with 64.0a1 (2018-09-25) and 63.0b9 on Win10x64, macOS10.13, Ubuntu 16.04 with the same lang-builds as reported one and can confirm as well that the issue is no longer encountered.
You need to log in before you can comment on or make changes to this bug.