Open Bug 1492122 Opened 2 years ago Updated 1 year ago

Geolocation is not displayed on some devices

Categories

(Firefox for Android :: General, defect, P3)

ARM
Android
defect

Tracking

()

Tracking Status
firefox-esr68 --- affected
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- fix-optional
firefox66 --- affected
firefox67 --- affected
firefox68 --- affected

People

(Reporter: stefan.deiac, Unassigned)

References

Details

Environment: 
Device:LG G4 (Android 5.1.0), Nokia 6 (Android 7.1.1);
Build: Nightly 64.0a1 (2018-09-17);

Steps to reproduce:
1. Go to https://google.com/maps
2. Tap on "Your location" button
3. Allow your location

Expected result:
Your location it's searched.

Actual result:
Your location is not searched even when you allow the permission.

Notes:
Not reproducible on Nexus 5 (6.0.1), Xiaomi Mi Pad 3 (Android 7.0), Samsung Galaxy S8 (Android 8.0.0), Google Pixel XL (Android 9) and Huawei MediaPad M2 (Android 5.1.1), Xiaomi Mi4i	(Android 5.0.2).
Here you have a video of the issue: https://drive.google.com/file/d/14aVvpQGSVLc-K2nPLEILEY_NgRGnF3QB/view?usp=sharing
Works using Wikipedia's nearby feature https://en.m.wikipedia.org/wiki/Special:Nearby and Google Maps for me on a Nexus 5x and Firefox for Android Nightly 64.0a1.
Duplicate of this bug: 1503257
Summary: Your location is not searched even when you allow the permission → Geolocation is not displayed on some devices
Working for me on Pixel2 with Android 9, nightly 65.  
It must be a device-specific issue. 
Does it work in Focus on those devices?
Flags: needinfo?(stefan.deiac)
Priority: -- → P3
Focus does not support geolocation.
Hi Liz, I tried to reproduce this issue with Samsung Galaxy Note 8(Android 8.0) and OnePlus 5T(Android 8.1.0) but I was not able. Also, I tried to reproduce on focus version, like Kevin mentioned, the focus version doesn't support geolocation.
It seems to be reproducible only on those devices mentioned on description.
Flags: needinfo?(stefan.deiac)

Hi,
I was able to reproduce the issue on Sony Xperia Z2 (Android 6.0.1) with 64.0.2 RC, but ONLY in private browsing.
Thank you!

Hi, i reproduced the issue with Samsung Galaxy J7(2016)(Android 6.0.1) on build Firefox Beta 68.0b10.

Reproduced with Google Pixel C (Android 8.0.0) on ESR Firefox Beta 68.1b8

You need to log in before you can comment on or make changes to this bug.