Closed Bug 1492183 Opened 2 years ago Closed 6 months ago

Crash in libhwui.so@0x8201e

Categories

(Firefox for Android :: General, defect, P3)

Unspecified
Android
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- fix-optional
firefox65 --- fix-optional

People

(Reporter: marcia, Unassigned)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is
report bp-fcb013ae-ad86-424c-8629-812a70180918.
=============================================================

#12 top crash on Fennec 62.0.1 release: https://bit.ly/2QAjT02. Also present on other branches. Devices all appear to be running API 26 and the following configuration comes up in correlations:

94.32% in signature vs 03.78% overall) android_board = msm8953
(94.32% in signature vs 04.03% overall) adapter_device_id = Adreno (TM) 506

Top 10 frames of crashing thread:

0 libc.so libc.so@0x4aab0 
1 libhwui.so libhwui.so@0x8201e 
2 libhwui.so libhwui.so@0x8201e 
3 libhwui.so libhwui.so@0x8c382 
4 liblog.so liblog.so@0x65fb 
5 libhwui.so libhwui.so@0x82df0 
6 liblog.so liblog.so@0x6616 
7 dalvik-non moving space (deleted) dalvik-non moving space @0x26e270 
8 dalvik-main space (region space) (deleted) dalvik-main space @0x1cb36267 
9 ashmem (deleted) ashmem @0x5e22d 

=============================================================
Mostly Motorola devices.

Mfg.         Device       Version    Architecture   #
motorola   moto g(6)      26 (REL)   armeabi-v7a   196   31.9%
motorola   Moto Z2 Play   26 (REL)   armeabi-v7a   149   24.3%
motorola   XT1635-02      26 (REL)   armeabi-v7a   128   20.8%
motorola   XT1635-01      26 (REL)   armeabi-v7a   103   16.8%
Moderately high volume crash on release 63.  
The crash volume for beta 64 looks lower than it was for beta 63, so I'm marking this fix-optional. The signature may have changed or may have been fixed in 64 by a patch in another bug.
I spent about and hour browsing urls from crash stats on the Moto Z2 Play. I did not encounter the crash. I did see a corrupt tile in one case.
Attached image corrupt tile
See Also: → 1510984
See Also: → 1374570

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.