Middle clicking on tab closes tab and loads some url in visible tab.

VERIFIED DUPLICATE of bug 107147

Status

--
major
VERIFIED DUPLICATE of bug 107147
17 years ago
10 years ago

People

(Reporter: virkkila, Assigned: jag+mozilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523
BuildID:    2002052309

When you middle-click on a tab it closes and the tab that is visible/becomes
visible will be loaded with some random (sometimes invalid) url.

Reproducible: Always
Steps to Reproduce:
1.Open a few tabs
2.middle-click on any of them


Actual Results:  
1. Tab 1 closes (as expected?)
2. The tab that is visible (was or became visible) is loaded with some
new/old/ivalid url


Expected Results:  
This is unclear, but I suppose only tab 1 should close an nothing else.


I have "middle click to open in new window" enabled.
(Reporter)

Comment 1

17 years ago
I am also seeing this bug in conjunction with Bug 117681. After some intensive
(and annoyingly involuntary) "testing" I noticed that at least for me the result
is the same. This is how it works: 

When I middle-click on a tab and close it, my current tab gets to thinking:

- "hey someone middle-clicked so we better load that url"
- "hey, there is no url there! let's check if anything is highlighted and then
check the clipboard"
- "Something is highlighted, we'll just stupidly asume it's an url and load it"
OR
- "We found some stuff on the clipboard, we'll try to load that as an url!"


Comment 2

17 years ago
workaround:

user_pref("middlemouse.contentLoadURL", false);

*** This bug has been marked as a duplicate of 107147 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.