navigator.mediaDevices.enumerateDevices() triggers App permission dialogs on Android

RESOLVED DUPLICATE of bug 1450762

Status

()

defect
P2
major
RESOLVED DUPLICATE of bug 1450762
11 months ago
9 months ago

People

(Reporter: jib, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Posted image screenshot1
STRs:
 1. If needed, revoke Camera and Microphone permissions from Firefox in Android's App Manager first.
 2. Open https://jsfiddle.net/jib1/LbtxeLvw/show
 3. Click the [Enumerate Devices!] button only.

Expected results:
 1. No prompt. An empty list of devices.

Actual results:
 1. Prompt appears: "Allow Firefox to take pictures and record video? [DENY] [ALLOW]" (see screenshot1)
 2. I click DENY.
 3. A second prompt appears: "Allow Firefox to record audio? [DENY] [ALLOW]" (see screenshot2)
 4. I click DENY.
 5. I get a list of one audioinput device.

From code inspection, it looks like this regressed in 55 (Bug 1369108).

This happens to me on various web sites where I wouldn't expect it. Presumably, some sites or JS library uses enumerateDevices() for fingerprinting.

I find no spec support for this method triggering permission prompts. The spec mentions permission only wrt device labels.

I'll file an issue on the spec asking for guidance.
Posted image screenshot2
Priority: -- → P2
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1450762
You need to log in before you can comment on or make changes to this bug.