Closed Bug 1493357 Opened 2 years ago Closed 2 years ago

Disable Protection button disables blocking all third-party cookies on mobile

Categories

(Firefox :: Protections UI, defect, P1)

ARM
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 1493682
Tracking Status
firefox63 + fixed
firefox64 + fixed

People

(Reporter: ehsan, Assigned: ehsan)

References

Details

(Keywords: regression)

Attachments

(1 obsolete file)

This bug is specific to Fennec.

STR:
1. Set network.cookie.cookieBehavior to 1.
2. Enable tracking protection.
3. Go to https://www.whatismybrowser.com/detect/are-third-party-cookies-enabled.
4. Disable protections in the site info dialog.
5. Check to see whether third-party cookies are enabled.

Actual Results: Yes

Expected Results: No
Priority: -- → P1
Comment on attachment 9011171 [details]
Bug 1493357 - Don't apply the content blocking allow list to mobile

Andrea Marchesini [:baku] has approved the revision.
Attachment #9011171 - Flags: review+
My patch in bug 1493682 addresses this, so there is no point in having two prefs for the same purpose.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1493682
Attachment #9011171 - Attachment is obsolete: true
fixed in bug 1493682
QA Contact: francois
QA Contact: francois
You need to log in before you can comment on or make changes to this bug.