Firefox hangs on macos mojave when downloading image file

RESOLVED DUPLICATE of bug 1489785

Status

()

defect
RESOLVED DUPLICATE of bug 1489785
7 months ago
7 months ago

People

(Reporter: jwir3, Unassigned)

Tracking

(Blocks 1 bug, {nightly-community})

unspecified
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox62 ?, firefox63 ?, firefox64 affected)

Details

(Reporter)

Description

7 months ago
Firefox Version:
Firefox Nightly 64.0a1, 64-bit (2018-09-23)
 
Operating System Details:

MacOS Mojave (10.14)
MacBook Pro (15 inch, Late 2015)
Processor: 2.7 GHz Intel Core i7
Memory: 16GB 2133 MHz, LPDDR3
Graphics: Radeon Pro 455 2048 MB, Intel HD Graphics 530 1536 MB

Steps to Reproduce:

1. Navigate to an image, such as https://locations.tgifridays.com/images/logo.png
2. Right click the image, select 'Save Image As'.
3. Select a folder on the local file system.
4. Select 'New Folder Button in the lower left corner of the popup.
5. Input new folder name, click Ok.
6. Attempt to change the name of the file.

Expected Results:
  - Browser will allow the name change of the file and download of the file to file system.

Actual Results:
  - Browser hangs, not allowing any UI input (e.g. closing window, attempting to quit, cancellation, etc...). Only possible recovery is switching to another application using CMD-tab, selecting the Apple menu from the top menu bar, choosing force quit, and force-quitting Firefox.

Notes:
  - I have noticed this behavior when downloading other files, as well as when I attempt to just download image files without creating a new folder, however, I can't consistently reproduce every time without using the 'new folder' use case.
Brindusa, could your team try and reproduce this bug? Does it also happen on 63 and 62? Thanks.
Blocks: mojave
Flags: qe-verify+
Flags: needinfo?(brindusa.tot)
This is a dupe of Bug 1489785 - we have been able to reproduce internally on some machines and it does affect all branches according to Ovidiu.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Flags: needinfo?(brindusa.tot)
Resolution: --- → DUPLICATE
Duplicate of bug: 1489785
You need to log in before you can comment on or make changes to this bug.