Closed Bug 1493549 Opened 11 months ago Closed 11 months ago

[mozprofile] Enable fake media streams (media.navigator.streams.fake) in web-platform-tests

Categories

(Testing :: web-platform-tests, enhancement)

enhancement
Not set

Tracking

(firefox64 fixed)

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: bob1211, Assigned: bob1211, NeedInfo)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.81 Safari/537.36




Expected results:

We should set media.navigator.streams.fake to true in the testing profile for WPT so that tests (e.g. webrtc) can `getUserMedia` from fake streams.
Since bug 905404 has been fixed, we can simply add a line to testing/profiles/web-platform-tests/user.js. I'll send a patch.
Assignee: nobody → bob1211
Status: UNCONFIRMED → ASSIGNED
Component: General → web-platform-tests
Ever confirmed: true
Comment on attachment 9011312 [details]
Bug 1493549 - Enable media.navigator.streams.fake in WPT

James Graham [:jgraham] has approved the revision.
Attachment #9011312 - Flags: review+
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/autoland/rev/6f81edbb4e87
Enable media.navigator.streams.fake in WPT r=jgraham
Update expectations
Comment on attachment 9011503 [details]
Bug 1493549 - Enable media.navigator.streams.fake in WPT

James Graham [:jgraham] has approved the revision.
Attachment #9011503 - Flags: review+
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/autoland/rev/5d1c5acc269a
Enable media.navigator.streams.fake in WPT r=jgraham
https://hg.mozilla.org/mozilla-central/rev/5d1c5acc269a
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
You need to log in before you can comment on or make changes to this bug.