Closed Bug 1493973 Opened Last year Closed Last year

RDM broken when chrome URLs disabled by policy

Categories

(DevTools :: Responsive Design Mode, defect)

60 Branch
defect
Not set

Tracking

(firefox-esr60 verified, firefox62 wontfix, firefox63 wontfix, firefox64 verified)

VERIFIED FIXED
Firefox 64
Tracking Status
firefox-esr60 --- verified
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- verified

People

(Reporter: peter.schlierf, Assigned: mkaply)

References

Details

(Keywords: regression)

Attachments

(4 files)

Attached image FF_RDM.png
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180920175354

Steps to reproduce:

1. Open menu
2. Open Web Developer
3. Start Responsive Design Mode (RDM)
or click CTRL + SHIFT + M 


Actual results:

Website which was loaded will hide and only a blank screen is visible.
It is not possible to disable the RDM mode anymore neither with Menu option nor with shortcut CTRL + SHIFT + M 


Expected results:

In Firefox 52 ESR the website was reduced to a smaller size.
It was possible to show the website in some different resolutions.
Component: Untriaged → Responsive Design Mode
Product: Firefox → DevTools
Forgot to add, that I reproduced this with following machines and Firefox 60 ESR versions:

Windows 10 64Bit -> 60.1.0 , 60.2.0 and 60.2.1 in 32Bit and also 60.2.0 and 60.2.1 in 64Bit
Windows 7 32Bit ->  60.1.0 , 60.2.0 and 60.2.1 in 32Bit
Windows 7 64Bit ->  60.1.0 , 60.2.0 in 32Bit and also 60.2.1 in 64Bit
Thanks for filing Paider. I just tested quickly on Windows 10, with Firefox ESR 60 (60.2.1esr 64-bit) but couldn't reproduce the issue so far.

Did this happen with one website in particular? Or just everywhere?
If you manage to make it happen again, could you please open the browser console (ctrl+shift+J) and checking if there are any JavaScript errors in there. If there are please would you paste them here?
Flags: needinfo?(peter.schlierf)
Yes, i can reproduce that on every website.
Just opened Mozilla.org and started RDM, same behaviour.
In Browser Console i only got following exception:

Exception { name: "", message: "Component returned failure code: 0x…", result: 2153644038, filename: "chrome://browser/content/browser.js", lineNumber: 1074, columnNumber: 0, data: null, stack: "_loadURIWithFlags@chrome://browser/…", location: XPCWrappedNative_NoHelper }

Also tested on 60.2.1esr (64-bit), Windows 10 1803.
FF configured by GPO and seperate CFG file for functions which are not able to configure by GPO.
Flags: needinfo?(peter.schlierf)
Just to confirm, you don't have developer tools turned off via GPO, do you?

Does this happen if Firefox is not configured by GPO and if you don't have your autoconfig?
(In reply to Mike Kaply [:mkaply] from comment #4)
> Just to confirm, you don't have developer tools turned off via GPO, do you?
> 
> Does this happen if Firefox is not configured by GPO and if you don't have
> your autoconfig?

I don't think that developer tools are disabled because Console and Debugger are running.

Attached a screenshot of our GPO settings, no Developer Tools disabled (but we are still on ADMX template 1.0)

And here our autoconfig file:

// Standard FF_Main_Policy.cfg File 
// 06/18/2018: Initial Version
// 07/20/2018: Change for PDF Viewer Enabling
// 07/26/2018: Change Proxy Setting from pref to defaultPref
// 08/23/2018: Changed "privacy.clearOnShutdown.history" and "privacy.clearOnShutdown.cache" true to false

// put everything in a try/catch
try {

// Deactivates AutoUpdate
lockPref("app.update.enabled", false);

// Check for AutoUpdate disabled
lockPref("app.update.auto", false);
lockPref("app.update.mode", 0);
lockPref("app.update.service.enabled", false);

// Deactivates compatibility check for Add-Ons
clearPref("extensions.lastAppVersion");
	
// Deactivates 'plug-in checking'
lockPref("plugins.hide_infobar_for_outdated_plugin", true);
clearPref("plugins.update.url");

// Do not ask for installation of Flash Plug-in
pref("plugins.notifyMissingFlash", false);
	
// Deactivates 'health reporter'
lockPref("datareporting.healthreport.service.enabled", false);

// Disable all data upload (Telemetry and FHR)
lockPref("datareporting.policy.dataSubmissionEnabled", false);

// Deactivates 'crash reporter'
lockPref("toolkit.crashreporter.enabled", false);
Components.classes["@mozilla.org/toolkit/crash-reporter;1"].getService(Components.interfaces.nsICrashReporter).submitReports = false;

// Do not check for Default Browser
pref("browser.shell.checkDefaultBrowser", false)

// Deactivate know your rights for the first start
pref("browser.rights.3.shown", true);

// Hide "What is new?" on the first start after update
pref("browser.startup.homepage_override.mstone", "ignore");

// Deactivate the internal PDF viewer
// pref("pdfjs.disabled", true);

// Use System Proxy
defaultPref("network.proxy.type", 5)
	
//Accept system certificates
pref("security.enterprise_roots.enabled", true);

//Start with Language like OS in MUI environment
pref("intl.locale.requested", "")

pref("browser.download.useDownloadDir", false)
pref("browser.newtabpage.storageVersion", 1)
lockPref("extensions.autoDisableScopes", 0); 
pref("javascript.options.baselinejit", true)
lockPref("network.IDN_show_punycode", true)
pref("network.prefetch-next", false)
pref("plugin.disable_full_page_plugin_for_types", "")
pref("plugin.load_flash_only", false)
pref("plugins.load_appdir_plugins", true)

// Cleanup on shutdown following stuff:
pref("privacy.clearOnShutdown.cache", false)
pref("privacy.clearOnShutdown.cookies", false)
pref("privacy.clearOnShutdown.downloads", false)
pref("privacy.clearOnShutdown.history", false)
pref("privacy.clearOnShutdown.formdata", true)
lockPref("privacy.clearOnShutdown.passwords", true)
pref("privacy.sanitize.sanitizeOnShutdown", true)
pref("privacy.donottrackheader.enabled", true)
//Required from proxy colleagues requested April 17
pref("security.cert_pinning.enforcement_level", 0)

// Request to support DNS request for single words
pref("browser.fixup.dns_first_for_single_words", true)

// Request for CRM eSales Webbrowsing
pref("dom.serviceWorkers.enabled", true)

//Disable unsecure password boxes
pref("security.insecure_field_warning.contextual.enabled", false)
pref("security.insecure_password.ui.enabled", false)

// TLS min and max level
pref("security.tls.version.max", 3)
pref("security.tls.version.min", 1)

// Close the try, and call the catch()
} catch(e) {displayError("Error in Firefox Web Configuration File:", e);}

I could not try without GPO and autoconfig as I am OOO till 10th of October unfortunately.
Attached image Firefox Policy Settings
I tested a little bit with the GPO and found out, that if you activate the setting "Mozilla\Firefox\DisableTelemetry" the Responsive Design Mode in Firefox does not work anymore!
Obviously it's a bug.
(In reply to Malte from comment #7)
> I tested a little bit with the GPO and found out, that if you activate the
> setting "Mozilla\Firefox\DisableTelemetry" the Responsive Design Mode in
> Firefox does not work anymore!
> Obviously it's a bug.

Hmm. I'm not seeing that. Are you sure there wasn't some other GPO involved? I'll test them all.
I tested again with a separate virtual machine.

GPO-Version: 1.2 (also tested on version 1.1)
OS: Win 10 64 Bit (1703, also tested on 1709)
Firefox: 60.2.2 ESR (32 Bit)

I set all policy definitions on default, but "Disable telemtry" on "true". I still have the problem that Responsive Mode is not working. There is a blank page.
Note: In this configuration when I activate the Responsive Design Mode with key CTRL + SHIFT + M it is active, but I cannot deactivate it, since I restart the browser.
I can recreate with telemetry off. Weird. Debugging.
Assignee: nobody → mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
it's the content policy to block about pages:

https://searchfox.org/mozilla-central/source/browser/components/enterprisepolicies/Policies.jsm#1003

It's blocking the chrome page used for RDM.
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/d0b593b6d065
Don't block devtools when block chrome URLs r=Felipe
https://hg.mozilla.org/mozilla-central/rev/d0b593b6d065
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Summary: Responsive Design Mode (RDM) not working → RDM broken when chrome URLs disabled by policy
Comment on attachment 9016776 [details]
Bug 1493973 - Don't block devtools when block chrome URLs

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1471355

User impact if declined: When about pages are blocked, can't access Responsive design mode.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: Disable about config or about telemetry in policy. Check if RDM works.

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Very self contained, one line to add an additional host.

This is a nice to have, but I understand if it is too late.

String changes made/needed:
Attachment #9016776 - Flags: approval-mozilla-beta?
Comment on attachment 9016776 [details]
Bug 1493973 - Don't block devtools when block chrome URLs

Sorry this is too late for 63RC, you should get QA to verify the fix and let it ride the trains to 64. Regards.
Attachment #9016776 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
See Also: → 1493341
Thanks for reproducing and solving the problem!
Will the functionality also be fixed in one of the 60 ESR versions or in the next ESR major release?
Hi, I managed to reproduce the issue in Firefox 63, But the issue no longer occurs in Firefox Beta 64.0b5 or the latest Nightly 65.0a1 (2018-11-01). I will mark this issue accordingly.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
See Also: 1493341
> Will the functionality also be fixed in one of the 60 ESR versions or in the next ESR major release?

Is this recreatable on ESR?
(In reply to Paider from comment #1)
> Forgot to add, that I reproduced this with following machines and Firefox 60
> ESR versions:
> 
> Windows 10 64Bit -> 60.1.0 , 60.2.0 and 60.2.1 in 32Bit and also 60.2.0 and
> 60.2.1 in 64Bit
> Windows 7 32Bit ->  60.1.0 , 60.2.0 and 60.2.1 in 32Bit
> Windows 7 64Bit ->  60.1.0 , 60.2.0 in 32Bit and also 60.2.1 in 64Bit

I only recreated this problem in 60 ESR.
Just tested on Windows 10 64Bit -> 60.3.0 ESR 32-Bit and I can also recreate.
(In reply to Mike Kaply [:mkaply] from comment #20)
> > Will the functionality also be fixed in one of the 60 ESR versions or in the next ESR major release?
> 
> Is this recreatable on ESR?

I only recreated this problem in 60 ESR.
Just tested on Windows 10 64Bit -> 60.3.0 ESR 32-Bit and I can also recreate.
Attached patch Patch for ESRSplinter Review
[ESR Uplift Approval Request]

If this is not a sec:{high,crit} bug, please state case for ESR consideration: Regression in policies that has been reported by some users

User impact if declined: Responsive Design Mode doesn't work in some cases

Fix Landed on Version: Firefox 64

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Just adds one more case to host check for content policy.

String or UUID changes made by this patch: None
Attachment #9023690 - Flags: approval-mozilla-esr60?
Comment on attachment 9016776 [details]
Bug 1493973 - Don't block devtools when block chrome URLs

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Policies

User impact if declined: Responsive Design Mode doesn't work in some cases.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Adds an additional case to if statement.

If there is another dot release, it would be nice to get this in.

String changes made/needed: None
Attachment #9016776 - Flags: approval-mozilla-release?
Comment on attachment 9023690 [details] [diff] [review]
Patch for ESR

Fix for dev tools to work with content policies. OK for ESR uplift.
Attachment #9023690 - Flags: approval-mozilla-esr60? → approval-mozilla-esr60+
Hi, I managed to reproduce this issue in Firefox 60.3.0esr but I can no longer reproduce it in Firefox 60.3.1esr (https://tools.taskcluster.net/index/gecko.v2.mozilla-esr60.latest.firefox/win64-opt), I will mark this issue accordingly.
Comment on attachment 9016776 [details]
Bug 1493973 - Don't block devtools when block chrome URLs

That doesn't seem like a good candidate for a dot release on our main consumer channel (marginal population impacted, 4 weeks until 64 is shipped so the by the time we ship the dot release with this patch and companies have deployed it, we will probably be about to ship 64 with the patch).
Attachment #9016776 - Flags: approval-mozilla-release? → approval-mozilla-release-
You need to log in before you can comment on or make changes to this bug.