Yahoo mailto broken by Yahoo changes

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
6 months ago
3 months ago

People

(Reporter: jscher2000, Unassigned, NeedInfo)

Tracking

62 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180920131237

Steps to reproduce:

With Yahoo! Mail selected as mailto client: 

(A) Clicked a mailto link and Firefox sent https://compose.mail.yahoo.com/?To=mailto:jscher2000@outlook.com 

(B) used Firefox's "Email Link" feature and Firefox sent https://compose.mail.yahoo.com/?To=mailto:?body=https%3A%2F%2Fwww.jeffersonscher.com%2Fres%2Fsumomarklets.html&subject=Bookmarklets%20for%20Mozilla%20Support%20Posts


Actual results:

Requests are redirected to a new message compose window without the expected information (no To for a mailto link, no Subject or Body content for "Email Link"). A user of Firefox 60 ESR reported the same, so it is not a Firefox 62-specific issue.


Expected results:

The information should be filled by a script on Yahoo's side. They broke it again.

If the handler URI is edited from 

https://compose.mail.yahoo.com/?To=%s

to 

https://compose.mail.yahoo.com/%s

in handlers.json, it works. However, this is a difficult workaround to recommend.

Can someone bother Yahoo! about this, please?

Meanwhile, a bookmarklet can work around the Email Link issue: https://www.jeffersonscher.com/res/sumomarklets.html#ymlink
Component: Untriaged → File Handling

Comment 1

6 months ago
I am one user that is also affected by this.
jscher2000's bookmarklet works for me.

But for some reason directly changing handlers.json in my profile does not work. It appears to be only if the "%s" immediately follows "https://compose.mail.yahoo.com/" which is broken. Experimenting with other strings placed before the "%s" shows that firefox does expand it in those cases. Something is probably different on my end for the protocol handlers

Updated

6 months ago
Component: File Handling → General
This is part of File Handling as the original impl (bug 413630) was filed in the component.
Component: General → File Handling

Comment 3

5 months ago
(In reply to Tim Guan-tin Chien [:timdream] (please needinfo) from comment #2)
> This is part of File Handling as the original impl (bug 413630) was filed in
> the component.

Possibly, but where the code is located is irrelevant until we identified which kind of product change has to be made, and whether this needs to be in Firefox or Yahoo Mail. Maybe this belongs to Developer Engagement / Outreach Request first?

Gijs, any suggestion on how to triage this correctly?
Flags: needinfo?(gijskruitbosch+bugs)

Comment 4

5 months ago
(In reply to :Paolo Amadini from comment #3)
> (In reply to Tim Guan-tin Chien [:timdream] (please needinfo) from comment
> #2)
> > This is part of File Handling as the original impl (bug 413630) was filed in
> > the component.
> 
> Possibly, but where the code is located is irrelevant until we identified
> which kind of product change has to be made, and whether this needs to be in
> Firefox or Yahoo Mail. Maybe this belongs to Developer Engagement / Outreach
> Request first?
> 
> Gijs, any suggestion on how to triage this correctly?

Updating client software on people's machines (including LTS-style stuff like ESR) appropriately for a web service like this changing its URIs whenever that happens seems like a losing proposition to me. I'd expect Yahoo Mail to have a stable endpoint to use, and the responsibility for restoring that to rest with them. The URL hasn't changed in over 5 years, and even then it looks like the change was to use "https" instead of "http" - otherwise the URI has been unchanged for 10 years.

Coincidentally, this change is apparently happening just as we're trying to make it easier for users to configure even their OS-level mail handler as being a web browser pointing to a web service (cf. bug 675428).

Maybe :mkaply or :mconnor knows how to triage this and/or what our contacts with Yahoo! are.
Flags: needinfo?(mozilla)
Flags: needinfo?(mconnor)
Flags: needinfo?(gijskruitbosch+bugs)
In this case, we're the ones that have it in our code:

https://searchfox.org/mozilla-central/source/browser/locales/en-US/chrome/browser-region/region.properties#18

So that seems like the only place we would need to change it.

Although I vaguely remember that we don't use this directly and it gets copied into the mimetypes file?

As far as contacts go, I'll leave that to mconnor.
Flags: needinfo?(mozilla)

Comment 6

5 months ago
(In reply to Mike Kaply [:mkaply] from comment #5)
> In this case, we're the ones that have it in our code:
> 
> https://searchfox.org/mozilla-central/source/browser/locales/en-US/chrome/
> browser-region/region.properties#18

Sure, but this is effectively a social contract with Yahoo that they provide something useful at that URL. We can't at all easily retro-spectively update all our copies of Firefox all over the world if they suddenly, unannounced, renege on that, and stop the URL working. Yes, it's in our code and we can update the URL in nightly, and then it'll take about 2-3 years for all (by which I really mean 95-99% of) the Firefox clients to stop trying to talk to it.

> So that seems like the only place we would need to change it.
> 
> Although I vaguely remember that we don't use this directly and it gets
> copied into the mimetypes file?

It's not so much that changing this URL would be hard if Yahoo needs us to change it, it's that the fact that they've broken the old URL without talking to anyone is not something we can fix anymore. Yes we can now change the URL we have, but it's not going to reach users for ages. (And yes, there's some murkiness about how this goes into mimetype files and whatnot, plus there are probably localized copies of the region.properties files that would also need updates, plus backporting, plus ...).


It'd be much easier for Yahoo to just make the URL do the right thing.

Comment 7

5 months ago
Tentatively WONTFIX to remove this from triage queues, as P5 might be misleading. Keeping needinfo for Mike Connor.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
FYI, the issue is that Yahoo no longer respects ?To=%s but DOES respect ?to=%s

Comment 9

4 months ago
This isn't resolved in Quantum 63.0.1 (64-bit).

I click on a mailto link, a Yahoo mail compose tab is opened, but there's no "to" information and no subject.  Please fix this.  it's really frustrating.

Comment 10

4 months ago
I get it that this can be complicated to fix globally.  Just tell me what specifically I need to change in the Handlers.json file and/or any other file and I'll gladly make those changes if it will get this to work. You can fix this globally later.  Right now, I just want this to work.
The working handler is https://compose.mail.yahoo.com/?to=%s (lower-case "to" instead of the current upper-case "To")

Comment 12

4 months ago
That didn't work.  I revised the handlers.json file according to the link above, but what I see when I click on an email link is something like "mailto:office@WhiteHouse.gov" That is, what winds up in the "to" field includes the word "mailto:", and not just "office@WhiteHouse.gov" which is what it should be. This always worked before.  Any other suggestions?
(Reporter)

Comment 13

4 months ago
Does anyone have a relationship with Yahoo to "evangelize" this issue with them? They still claim in their documentation that this is supposed to work. https://help.yahoo.com/kb/mail-for-desktop/SLN24051.html

Comment 14

4 months ago
No, it really doesn't work.

Comment 15

4 months ago
I opened a case with Yahoo Mail Pro support today.  After trying to do their normal troubleshooting, they escalated the case to their tier two group.  We'll see if that helps.
(Reporter)

Comment 16

3 months ago
Meanwhile, I created an extension: https://addons.mozilla.org/firefox/addon/yahoo-mail-email-link-fix/

Comment 17

3 months ago
(In reply to jscher2000 from comment #16)
> Meanwhile, I created an extension:
> https://addons.mozilla.org/firefox/addon/yahoo-mail-email-link-fix/

The new addon doesn't seem to be working for me.  I think it may be because I changed the information in the handler to 

 https://compose.mail.yahoo.com/?to=%s

I think this may be wrong.  Could you please clarify what the addon expects in the handler file?

Comment 18

3 months ago
Thanks jscher2000!
The add-on worked for me.

Karen, did you use the new right-click context menu entry or Firefox's email link button?

Comment 19

3 months ago
I used the right-mouse click menu.  A new Compose email screen opened but no information was filled into the TO field.
(Reporter)

Comment 20

3 months ago
(In reply to Karen Grube from comment #17)
> (In reply to jscher2000 from comment #16)
> > Meanwhile, I created an extension:
> > https://addons.mozilla.org/firefox/addon/yahoo-mail-email-link-fix/
> 
> The new addon doesn't seem to be working for me.  I think it may be because
> I changed the information in the handler to 
> 
>  https://compose.mail.yahoo.com/?to=%s
> 
> I think this may be wrong.  Could you please clarify what the addon expects
> in the handler file?

The add-on doesn't use the built-in handler URL, it constructs its own URL and opens it in a new tab.

The URL and menu command change depending on where you right-click:

(1) Right-click an email link => "New Yahoo Mail message"

This replaces Firefox's left-click-on-email-link and sends ?to=address.

Note: If you right-click on a link whose URL doesn't start with mailto: then you get a new message with Shared Link in the subject line.

(2) Right-click a blank area of the page when no text is selected => "New Yahoo Mail message (page title, URL)"

This replaces Firefox's Email Link command and sends ?subject=title&body=url.

Comment 21

3 months ago
(In reply to jscher2000 from comment #20)
> (In reply to Karen Grube from comment #17)
> > (In reply to jscher2000 from comment #16)
> > > Meanwhile, I created an extension:
> > > https://addons.mozilla.org/firefox/addon/yahoo-mail-email-link-fix/
> > 
> > The new addon doesn't seem to be working for me.  I think it may be because
> > I changed the information in the handler to 
> > 
> >  https://compose.mail.yahoo.com/?to=%s
> > 
> > I think this may be wrong.  Could you please clarify what the addon expects
> > in the handler file?
> 
> The add-on doesn't use the built-in handler URL, it constructs its own URL
> and opens it in a new tab.
> 
> The URL and menu command change depending on where you right-click:
> 
> (1) Right-click an email link => "New Yahoo Mail message"
> 
> This replaces Firefox's left-click-on-email-link and sends ?to=address.
> 
> Note: If you right-click on a link whose URL doesn't start with mailto: then
> you get a new message with Shared Link in the subject line.
> 
> (2) Right-click a blank area of the page when no text is selected => "New
> Yahoo Mail message (page title, URL)"
> 
> This replaces Firefox's Email Link command and sends ?subject=title&body=url.

Maybe I just don't get it.  I go to the following web page for the U.S. Senate . . .

https://www.senate.gov/general/contacting.htm

On that page there is a link that says "contact the webmaster" about half-way down the page.

The code behind that link says . . . 

<a href="mailto:webmaster@sec.senate.gov">webmaster</a>

When I right-mouse click on that link and select New Yahoo Mail Message from the right-mouse-click-window, a new Yahoo mail tab opens, but no new "compose email" screen and nothing is filled in for the 'to" or "subject."

I'm not sure why this isn't working.  Any suggestions?
(Reporter)

Comment 22

3 months ago
(In reply to Karen Grube from comment #21)
> I go to the following web page for the U.S.
> Senate . . .
> 
> https://www.senate.gov/general/contacting.htm
> 
> On that page there is a link that says "contact the webmaster" about
> half-way down the page.
> 
> The code behind that link says . . . 
> 
> <a href="mailto:webmaster@sec.senate.gov">webmaster</a>
> 
> When I right-mouse click on that link and select New Yahoo Mail Message from
> the right-mouse-click-window, a new Yahoo mail tab opens, but no new
> "compose email" screen and nothing is filled in for the 'to" or "subject."
> 
> I'm not sure why this isn't working.  Any suggestions?

Oh... does the address bar show something like this:

https://mail.yahoo.com/neo/launch?.src=ym&reason=unexpected_ymv

Sorry, I didn't test with the "Classic" Yahoo mail, only the current version. I don't know what URL works for Classic at this point. I will update the extension description so people know about this limitation.

Did you try the new version and switch back? There may be a blue box at the bottom of the left column that says "One click away from your upgraded Inbox" switch switches to the new version. In the new version, a button to switch back is at the bottom of the Settings menu.

Comment 23

3 months ago
(In reply to jscher2000 from comment #22)
> (In reply to Karen Grube from comment #21)
> > I go to the following web page for the U.S.
> > Senate . . .
> > 
> > https://www.senate.gov/general/contacting.htm
> > 
> > On that page there is a link that says "contact the webmaster" about
> > half-way down the page.
> > 
> > The code behind that link says . . . 
> > 
> > <a href="mailto:webmaster@sec.senate.gov">webmaster</a>
> > 
> > When I right-mouse click on that link and select New Yahoo Mail Message from
> > the right-mouse-click-window, a new Yahoo mail tab opens, but no new
> > "compose email" screen and nothing is filled in for the 'to" or "subject."
> > 
> > I'm not sure why this isn't working.  Any suggestions?
> 
> Oh... does the address bar show something like this:
> 
> https://mail.yahoo.com/neo/launch?.src=ym&reason=unexpected_ymv
> 
> Sorry, I didn't test with the "Classic" Yahoo mail, only the current
> version. I don't know what URL works for Classic at this point. I will
> update the extension description so people know about this limitation.
> 
> Did you try the new version and switch back? There may be a blue box at the
> bottom of the left column that says "One click away from your upgraded
> Inbox" switch switches to the new version. In the new version, a button to
> switch back is at the bottom of the Settings menu.


Yes, that's exactly what the url shows!  I'm not using the new Yahoo Mail at this point, until they restore the right-mouse click options to an email (where you can label it spam, delete it, forward it, etc.) and move the trash can back to the left side next to the search button on an email.  But I can tell you that it works in the New Yahoo Mail. That's great!  But if you can find a way to make this work with Classic Yahoo Mail, that would be even better.

Thanks so much!
You need to log in before you can comment on or make changes to this bug.