It is nigh on impossible to work out the point of origin of an event in its source element

RESOLVED DUPLICATE of bug 69787

Status

()

enhancement
P4
normal
RESOLVED DUPLICATE of bug 69787
17 years ago
9 years ago

People

(Reporter: chris, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

This will be marked as a duplicate bug of others i am sure BUT with the current 
event system its impossible to find out where an event has originated from its 
target (e.g. the coordinates within an HTMLImageElement). This is prohibitive 
to all sorts of coding (unless you make all your elements position:absolute and 
use the layerX/layerY properties). I can think of a number of very important 
situations where this would be absolutely critical (not to mention a number of 
unimportant applications).  Without these properties (IE has 
event.offsetX/event.offsetY) most DHTML apps that do anything more complex than 
mouseovers will suffer (mine are right now :-( ) (unless as i said everything 
is pos:absolute; which is ridiculous)
(PS I am currently using event.clientX-event.layerX but this does not guarentee 
results for multiple nesting, nor do i have which layer the layerX is relative 
to to hack that, though i guess a while loop looking at offset properties might 
work)
Confirming enhancement request, I cant find anything about this in the spec. As
I understand this is request for a property of an event to specify coordinates
relative to the currentTarget (offset from its top,left coordinates).
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P4
Assignee: joki → events
OS: Windows 2000 → All
QA Contact: vladimire → ian
Hardware: PC → All
Assignee: events → nobody
QA Contact: ian → events
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 69787
You need to log in before you can comment on or make changes to this bug.